Rightmost Digit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 44116 Accepted Submission(s): 16603
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6HintIn the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
该题目是快速幂模板题,刚刚学习。
#include <stdio.h>
int PowerMod(int a,int b,int c)
{
int ans;
ans=1;
a=a%c;
while(b>0)
{
if(b%2)
ans=(ans*a)%c;
b/=2;
a=(a*a)%c;
}
return ans;
}
int main()
{
int n,b,T;
int ans;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
ans=PowerMod(n,n,10);
printf("%d\n",ans);
}
return 0;
}