POJ 3096 Surprising Strings(STL map)

27 篇文章 0 订阅
3 篇文章 0 订阅

Surprising Strings
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6569 Accepted: 4268

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source


题意:

定义D-pairs表示取字符串s中相距为D的两个字母所构成的字母对,该字母对中两个字母的位置顺序与他们在主串s中的位置顺序一致

定义D-unique表示,若从字符串s中取出所有相距为D的字母对D-pairs,且这些D-pairs都是独一无二的,那么成字符串s是一个D-unique

D的取值范围为0~s.len()-2

假如字符串s对于所有的D都有D-unique成立,则字符串s是令人惊讶的 = =

层次关系:

对于某个D,当所有D-pairs都不同时,sD-unique

对于所有Ds都有D-unique时,它是surprising string


分析:

这里用到map容器,个人感觉map容器的使用在某方面和数组是使用差不多。

map< struct first,struct second >;

first和second可以为任意类型,使用的时候可以map[ first ] = second;添加

map容器中不能有相同的数值,具体内容参考:http://www.kuqin.com/cpluspluslib/20071231/3265.html

该题目中用到的是,map < string , bool > 来判断是否已经存在。

代码如下:

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <map>
using namespace std;
int main()
{
	char str[85];
	int i,j,k;
	while(scanf("%s",str),str[0]!='*')
	{
		int len=strlen(str);
		if(len<=2)
		{
			printf("%s is surprising.\n",str);
			continue;
		}
		else
		{
			bool sign=true;		//判断成功的标志 
			for(i=0;i<=len-2;i++)	//相隔的位数d 
			{
				map <string,bool> temp;
				for(j=0;j<=len-i-2;j++)		//循环判断把每一个pari存入temp; 
				{
					char pair[3]={str[j],str[j+i+1],'\0'};
					if(!temp[pair])
						temp[pair]=true;
					else
					{
						sign=false;break;
					}
					
				}
				
				if(sign==false)
					break;
			}
			if(sign)
				printf("%s is surprising.\n",str);
			else
				printf("%s is NOT surprising.\n",str);
			
		}
		
	}
	
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值