POJ 1753 Flip Game(回溯查找,dfs)

27 篇文章 0 订阅
23 篇文章 0 订阅
Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39171 Accepted: 17026

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:一个4*4的棋盘中有若干黑子和若干白子,现要求翻动最少次数使得棋盘上都是白字或都是黑子

翻动要求,翻动一个棋子,其上下左右的棋子都会翻转颜色。

若没有符合不能翻转到符合要求,则输出Impossible

代码如下:

#include <stdio.h>
char str[5][5];
int dir[5][2]={-1,0,0,1,1,0,0,-1,0,0};
int Max;

int judge()
{
	int peace1=0,peace2=0;
	for(int i=0;i<4;i++)
	{
		for(int j=0;j<4;j++)
		{
			if(str[i][j]=='b')
				peace1=1;
			else
				peace2=1;
		}
	}
	if(peace1==1 && peace2==1)
		return 0;
	return 1;
}

void backtrack(int t,int x,int y,int max)
{	
	if(max>Max)
		return ;
	if(t==16)
	{
		if(judge())
			if(max<Max)
				Max=max;
		return;
	}
		
	backtrack(t+1,(t+1)/4,(t+1)%4,max);
	
	for(int i=0;i<5;i++)
	{
		int px=x+dir[i][0],py=y+dir[i][1];
		if(px<0 || px>=4 || py<0 || py>=4)
			continue;
		if(str[px][py]=='b')
			str[px][py]='w';
		else
			str[px][py]='b';
	}
	backtrack(t+1,(t+1)/4,(t+1)%4,max+1);
	for(int i=0;i<5;i++)
	{
		int px=x+dir[i][0],py=y+dir[i][1];
		if(px<0 || px>=4 || py<0 || py>=4)
			continue;
		if(str[px][py]=='b')
			str[px][py]='w';
		else
			str[px][py]='b';
	}
}

int main()
{
	int i,j;
	Max=1000;
	for(i=0;i<4;i++)
		scanf("%s",str[i]);
	backtrack(0,0,0,0);
	if(Max==1000)
		printf("Impossible\n");
	else
		printf("%d\n",Max);
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值