POJ - 1753 Flip Game

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:给你一个4X4的棋盘,黑白子用b,w表示,要求通过翻转最少棋子来使棋盘呈现全白或全黑状态,注意每次翻转棋子时此棋子上下左右的棋子跟着翻转。

贴代码:dfs一个棋子只有两种情况,翻转或者不翻转,那么从第一个棋子开始翻转,直到出现要求状态。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int minn;
int nextt[5][2]= {{0,1},{1,0},{0,-1},{-1,0},{0,0}};//自己本身也要翻转。
char mp[6][6];
int check()//检查是否出现全白全黑的情况。
{
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
            if(mp[i][j]!=mp[0][0])
                return 0;
    return 1;
}
void lin(int x,int y)//改变棋子(x,y)及其周围棋子的状态。
{
    int tx,ty;
    for(int i=0; i<=4; i++)
    {
        tx=x+nextt[i][0];
        ty=y+nextt[i][1];
        if(tx<0||ty<0||tx>=4||ty>=4)
            continue;
        if(mp[tx][ty]=='b')
            mp[tx][ty]='w';
        else
            mp[tx][ty]='b';
    }
}
void dfs(int x,int y,int step)
{
    if(check())
    {
        if(step<minn)//找到最小值。
            minn=step;
        return ;
    }
    if(x==4)
        return ;//行数找完却还未满足。
    lin(x,y);
    //翻转此棋子的时候。
    if(y==3)
        dfs(x+1,0,step+1);
    else
        dfs(x,y+1,step+1);
    lin(x,y);
    //不翻转。此时调用channge函数是为了回到之前的状态
    if(y==3)
        dfs(x+1,0,step);
    else
        dfs(x,y+1,step);

}
int main()
{
    int i,j;
    minn=99999;
    for(i=0; i<4; i++)
        scanf("%s",mp[i]);
    dfs(0,0,0);
    if(minn<=16)
        printf("%d\n",minn);
    else
        printf("Impossible\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值