POJ 3050 Hopscotch (回溯枚举)

40 篇文章 0 订阅
27 篇文章 0 订阅

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3373 Accepted: 2326

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Source


题意:跳格子,从任意格子开始,跳6个格子(可以上下左右跳,跳过的格子可以重复跳),组成6位数字,求最多组成几个6位数字

分析:枚举所有情况。

代码如下:

#include <stdio.h>
#include <string.h>
int map[10][10];
int ans[1000000];
int num=0;
int dir[4][2]={-1,0,0,1,1,0,0,-1};
void dfs(int x,int y,int t,int count)
{
	
	if(x>5 || y>5 ||x<1 ||y<1)
		return ;
	if(t==5)
	{
		//printf("<%d %d %d %d>\n",x,y,t,count);
		if(ans[count]==0)
		{
			ans[count]=1;
			num++;
		}
		return ;
	}
	for(int k=0;k<4;k++)
	{
		int px=dir[k][0]+x;
		int py=dir[k][1]+y;
		dfs(px,py,t+1,count*10+map[px][py]);
	}
} 

int main()
{
	int i,j;
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			scanf("%d",&map[i][j]);
	memset(ans,0,sizeof(ans));
	for(i=1;i<=5;i++)
	{
		for(j=1;j<=5;j++)
		{
			dfs(i,j,0,map[i][j]);
		}
	}
	printf("%d\n",num);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值