Hopscotch POJ - 3050

题目:

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题意:

在一个5*5的地图中,你可以向周围的四个方向前进一步,让你求出来行走6步可以形成的数字的个数(不重复);

每一个位置都是可以重复行走的;

思路:

需要注意起点可以是地图上的任意一个位置,所以要对所有的点进行遍历(图很小,所以不会超时);

走路形成的数字可以用一个set容器进行存储,因为set可以去重;

然后直接对这个图进行广搜;

代码如下:

#include<set>
#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int map[6][6];//地图;

struct node
{
    int x;
    int y;
    int s;//走路形成的数字;
    int step;//步数;
};

queue<node>Q;
set<int>se;//set容器去重;

int nextt[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};

node a,next;

void bfs(int xx,int yy)
{
    a.x=xx;
    a.y=yy;
    a.s=map[xx][yy];
    a.step=1;
    Q.push(a);
    while(!Q.empty())
    {
        a=Q.front();
        Q.pop();
        if(a.step==6)//形成了一个6位数;
            se.insert(a.s);
        for(int i=0; i<4; i++)
        {
            next.x=a.x+nextt[i][0];
            next.y=a.y+nextt[i][1];
            if(next.x<0||next.x>=5||next.y<0||next.y>=5)//越界;
                continue;
            next.step=a.step+1;
            next.s=a.s*10+map[next.x][next.y];//数字;
            if(next.step<=6)//剪枝;
                Q.push(next);
        }
    }
    return ;
}

int init()//开始的起点,依次遍历;
{
    for(int i=0; i<5; i++)
    {
        for(int j=0; j<5; j++)
        {
            bfs(i,j);
        }
    }
    return se.size();//可以形成的数字的个数;
}

int main()
{
    for(int i=0; i<5; i++)
    {
        for(int j=0; j<5; j++)
        {
            scanf("%d",&map[i][j]);
        }
    }
    int kk=init();
    printf("%d\n",kk);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值