A Knight's Journey
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 42114 | Accepted: 14324 |
Description
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
If no such path exist, you should output impossible on a single line.
Sample Input
3 1 1 2 3 4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
题意:一个骑士,可以跳8个方向(和中国象棋的马类似,如图),给出一个n*m的矩阵,判断能否全都遍历一遍,能的话输出字典序最小的序列。
分析:
一看题目就是简单的dfs,只是要求输出字典序最小的序列,所以遍历顺序需要有所限制。
如图遍历即可得到字典序最小的序列。
代码如下:
#include <stdio.h>
#include <string.h>
int n,m;
int map[30][30];
char a[30][3];
int peace;
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
void dfs(int t,int x,int y){
int i;
if(peace)
return ;
if(t>=n*m)
{
peace=1;
return ;
}
for(i=0;i<8;i++)
{
int px = x+dir[i][0];
int py = y+dir[i][1];
if(!map[px][py] && !(px<=0 || py<=0 || px>n || py>m) && !peace)
{
a[t][0]='A'+py-1;
a[t][1]=px+'0';
map[px][py]=1;
dfs(t+1,px,py);
map[px][py]=0;
}
}
}
int main()
{
int T;
int i,j;
int cnt = 0;
scanf("%d",&T);
while(T--)
{
memset(map,0,sizeof(map));
memset(a,0,sizeof(a));
scanf("%d %d",&n,&m);
peace=0;
map[1][1]=1;
a[0][0]='A';
a[0][1]='1';
dfs(1,1,1);
printf("Scenario #%d:\n",++cnt);
if(peace)
{
for(i=0;i<n*m;i++)
printf("%c%c",a[i][0],a[i][1]);
}
else
printf("impossible");
putchar('\n');
putchar('\n');
}
return 0;
}