uva 1335 Beijing Guards(二分)

                              uva 1335 Beijing Guards


Beijing was once surrounded by four rings of city walls: the Forbidden City Wall, the Imperial City Wall, the Inner City Wall, and finally the Outer City Wall. Most of these walls were demolished in the 50s and 60s to make way for roads. The walls were protected by guard towers, and there was a guard living in each tower. The wall can be considered to be a large ring, where every guard tower has exaetly two neighbors.

The guard had to keep an eye on his section of the wall all day, so he had to stay in the tower. This is a very boring job, thus it is important to keep the guards motivated. The best way to motivate a guard is to give him lots of awards. There are several different types of awards that can be given: the Distinguished Service Award, the Nicest Uniform Award, the Master Guard Award, the Superior Eyesight Award, etc. The Central Department of City Guards determined how many awards have to be given to each of the guards. An award can be given to more than one guard. However, you have to pay attention to one thing: you should not give the same award to two neighbors, since a guard cannot be proud of his award if his neighbor already has this award. The task is to write a program that determines how many different types of awards are required to keep all the guards motivated.

Input 

The input contains several blocks of test eases. Each case begins with a line containing a single integer l$ \le$n$ \le$100000, the number of guard towers. The next n lines correspond to the n guards: each line contains an integer, the number of awards the guard requires. Each guard requires at least 1, and at most l00000 awards. Guard i and i + 1 are neighbors, they cannot receive the same award. The first guard and the last guard are also neighbors.

The input is terminated by a block with n = 0.

Output 

For each test case, you have to output a line containing a single integer, the minimum number x of award types that allows us to motivate the guards. That is, if we have x types of awards, then we can give as many awards to each guard as he requires, and we can do it in such a way that the same type of award is not given to neighboring guards. A guard can receive only one award from each type.

Sample Input 

3
4
2
2
5
2
2
2
2
2
5
1
1
1
1
1
0

Sample Output 

8
5
3



题目大意:有n个人为成一个圈,其中第i个人想要r[i]种不同的礼物,相邻的两个人可以聊天,炫耀自己的礼物。如果两个相邻的人拥有同一种礼物,则双方都会很不高兴,问最少需要多少种不同的礼物才能满足所有人的需求。

解题思路(转): 

      1. 当n为偶数时, 答案是相邻两人之间的的r值最大和, 即p = max{ ri + ri+1 }.

      2. 当n为偶数时, 采用二分求解, 假设p种礼物是否满足分配:

      假设: 第一个人得到礼物1~r1, 分配的策略可以是: 偶数编号的人尽量往前取, 奇数的人尽量往

            后取. 这样需要第n个人在不冲突的条件下, 尽量可能的往后取rn样礼物. 最后判断编号1

            和编号n的人是否冲突即可.

            例: p = 8, r = {2,2,5,2,5}

             第一人:{1,2},第二人:{3,4}, 第三人:{8,7,6,5,2}, 第四人:{1,3}, 第五人:{8,7,6,5,4}




#include<stdio.h>
#include<algorithm>
using namespace std;
int p[100005], left[100005], right[100005], n; //left:第i个人拿到的左边的礼物总数。right同
int check(int x) {//x个礼物,是否够分
	int a = p[1], b = x - p[1]; //向左取和向右取
	left[1] = a; right[1] = 0;
	for (int i = 2; i <= n; i++) {
		if (i % 2 != 0) {
			right[i] = min(b - right[i - 1], p[i]); //尽量拿右边的礼物
			left[i] = p[i] - right[i];
		}
		else {
			left[i] = min(a - left[i - 1], p[i]);//尽量拿左边的礼物
			right[i] = p[i] - left[i];
		}
	}
	return left[n] == 0;
}
int main() {
	while (scanf("%d", &n) == 1, n) {
		for (int i = 1; i <= n; i++) {
			scanf("%d", &p[i]);
		}	
		int L = 0, R = 0;
		p[n + 1] = p[1];
		for (int i = 1; i <= n; i++) {
			L = max(L, p[i] + p[i + 1]);
			R += p[i];
		}
		if (n == 1) {//需要特判
			printf("%d\n", p[1]);
			continue;
		}
		if (n % 2 != 0) {
//			for (int i = 1; i <= n; i++) {
//				R = max(R, p[i] * 3);
//			}
			while (L < R) { //二分
				int mid = (L + R) / 2;
				if (check(mid)) R = mid;
				else L = mid + 1;
			}
		}
		printf("%d\n", L);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值