uva 270 Lining Up (几何)

                                     uva 270 Lining Up




``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3



题目大意:给出一系列的点, 求最多有多少个点能连成一条线。

解题思路:当三点共线时:A(X1,Y1),B(X2,Y2),C(X3,Y3) ————> (Y2-Y1)/(X2-X1) = (Y3-Y2)/(X3-X2)





#include <stdio.h>  
#include <string.h>  
#include <stdlib.h>  
#include<algorithm>
using namespace std;
int X[1005], Y[1005], cnt, Max;  
int CNT(int a, int b, int c) { //计算在这条线上的点的数量 
	int cnt2 = 0;  
	for (int i = c + 1; i < cnt; i++) {  
		if (a * (Y[i] - Y[c]) == b * (X[i] - X[c])) cnt2++;  
	}  
	return cnt2;  
}  
int findMax() {  
	for (int i = 0; i < cnt; i++) {  
		for (int j = i + 1; j < cnt; j++) {  
			int temp = CNT(X[j] - X[i], Y[j] - Y[i], j) + 2;  //本身两个点
			Max = max(Max, temp);  
		}  
	}  
}  
char s[1005];
int main() {  
	int T;  
	scanf("%d%*c%*c", &T); //注意读空行 
	while (T--) {  
		cnt = 0;
		while (gets(s)) {  
			if (!s[0] && cnt) break;  
			sscanf(s, "%d%d", &X[cnt], &Y[cnt]);  
			cnt++;
		}  
		Max = -1;
		findMax();
		printf("%d\n", Max);  
		if (T) printf("\n");
	}  
	return 0;  
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值