hdu 5373 The shortest problem

hdu 5373 The shortest problem

Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.

Input
Multiple input.
We have two integer n (0<=n<=104 ) , t(0<=t<=105) in each row.
When n==-1 and t==-1 mean the end of input.

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.

Sample Input

35 2
35 1
-1 -1

Sample Output

Case #1: Yes
Case #2: No

题目大意:给出一个数n,和进行的操作数t。每次进行操作,就把当前数的每一位上的数字相加,然后把相加得出的数字放在原数字的最后,获得新的数字,然后以新的数字进行下一次操作。操作结束后,问最后的数能否被11整除。
解题思路:可以被11整除的数有个特征,奇数位之和和偶数位之和之差,可以整除11。根据这个特征,去模拟操作。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;

typedef long long ll;
int n, m, flag, val, sum;
int digit[20];

int solve(int x) {
    int sum = 0, move = 0;
    while (x) {
        sum += x % 10;  
        digit[move++] = x % 10;
        x /= 10;
    }
    for (int i = move - 1; i >= 0; i--) {
        val += flag * digit[i]; 
        flag = -flag;
    }
    return sum;
}

int main() {
    int Case = 1;
    while (scanf("%d %d", &n, &m) == 2) {
        if (n == -1 && m == -1) break;
        printf("Case #%d: ", Case++);   
        if (n == 0) {
            printf("Yes\n");
            continue;
        }
        if (m == 0) {
            if (n % 11) printf("No\n");
            else printf("Yes\n");
            continue;
        }
        flag = 1;
        val = 0;
        sum = solve(n);
        for (int i = 0; i < m; i++) {
            sum += solve(sum);  
        }       
        if (val % 11) printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值