uva 1494 Qin Shi Huang's National Road System (次小生成树)

                  uva 1494 Qin Shi Huang's National Road System



Description

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input

The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input

    
    
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output

    
    
65.00 70.00
 



题目大意:秦朝有n个城市,需要修建一些道路使得任意两个城市之间都可以连通。道士徐福声称他可以用法术修路,不花钱,也不用劳动力,但法力有限,只能修一条。秦始皇不仅希望其他道路的总长度B尽量短,而且希望,用法术修的这条路所连接的两个城市的人口之和A尽量大。你的任务是求出A / B的最大值。

解题思路:用求次小生成树的方法求出Max数组,也就是找出最小生成树上点到点之间的最大权值边。然后遍历所有边,A = people[i] + people[j], B = Prim() - Max[i][j],维护A / B。



#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;

typedef long long ll;
const int N = 1005;
const int M = N * (N / 2); 
const int INF = 0x3f3f3f3f;
int n;
struct City{
	double x, y;
	int p;
}c[N];
bool vis[N], used[N][N];
int pre[N];
double dis[N][N];
double Max[N][N], lowc[N];

void init() {
	memset(vis, false, sizeof(vis));
	memset(used, false, sizeof(used));
	vis[1] = true;
	pre[1] = -1;
	lowc[1] = 0;
	for (int i = 2; i <= n; i++) {
		lowc[i] = dis[1][i];
		pre[i] = 1;
	}
}

double getDis(int x, int y) {
	return sqrt(pow(c[x].x - c[y].x, 2) + pow(c[x].y - c[y].y, 2));	
}

void input() {
	memset(dis, INF, sizeof(dis));
	for (int i = 1; i <= n; i++) {
		scanf("%lf %lf %d", &c[i].x, &c[i].y, &c[i].p);	
	}
	for (int i = 1; i <= n; i++) {
		for (int j = i + 1; j <= n; j++) {
			dis[i][j] = dis[j][i] = getDis(i, j);	
		}	
	}
}

double prim() {
	double ans = 0;
	for (int i = 2; i <= n; i++) {
		double minc = INF;	
		int p = 1;
		for (int j = 1; j <= n; j++) {
			if (!vis[j] && minc > lowc[j]) {
				minc = lowc[j];	
				p = j;
			}	
		}
		if (pre[p] != -1) {
			used[pre[p]][p] = used[p][pre[p]] = true;	
			for (int j = 1; j <= n; j++) {
				if (vis[j]) {
					Max[j][p] = Max[p][j] = max(Max[j][pre[p]], lowc[p]);	
				}	
			}
		}
		ans += minc;
		vis[p] = true;
		for (int j = 1; j <= n; j++) {
			if (!vis[j] && lowc[j] > dis[p][j]) {
				lowc[j]	= dis[p][j];
				pre[j] = p;
			}	
		}
	}
	return ans;
}

void solve() {
	double MST = prim();
	double ans = -1;
	for (int i = 1; i <= n; i++) {
		for (int j = i + 1; j <= n; j++) {
			//减去i到j的最大权值边,保证生成树其余边的和最小
			double temp = MST - Max[i][j];
			//法术完成的边的两端的城市的人口和
			double num = c[i].p + c[j].p;
			ans = max(ans, num / temp);
		}	
	}
	printf("%.2f\n", ans);
}

int main() {
	int T;
	scanf("%d", &T);
	while (T--) {
		scanf("%d", &n);		
		input();
		init();
		solve();
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值