SDNU 1334.Jason's Water Problem 向量的叉积求多边形面积


1334.Jason's Water Problem

Description

Calculus is the first lesson Jason had. It is tedious, so an interesting idea occurred to Jason. He took out his mobile phone and open the HDUOJ and found a water problem. He said to himself, “I must solve this f**king easy water problem in ten minutes! ”.

You were invited to compete with him online. Don’t be defeated.


Input

Multiple test cases, Each test first contains an integer N(3<=N<=100000) indicating the number of vertices of the polygon. The i-th of the following N lines contains two integers xi and yi (0<=xi,yi<=10^9) separated by a blank. (xi,yi) is the i-th vertex of the polygon, and (x1,y1),...,(xn,yn) will be in counterclockwise order.


Output

For each test case, output a number as the answer which is the area of the polygon be multiplied by 2. In case the answer is greater than 1000000006, please modulo the answer with 1000000007.


Sample Input

3
0 0
1 0
0 1
4
0 0
1 0
1 1
0 1

Sample Output

1

2


    逆时针顺序给出一个多边形的顶点,求这个多边形的面积,直接套用公式,向量叉积来求就可,即S=x1*y2-x2*y1+...+xn*y1-x1*yn,不过不知道SDNU的OJ是什么情况,最后一步的时候不mod就能过,mod就过不了.....不应该没什么区别么= =

    下面AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<math.h>
using namespace std;
const long long mod=1000000007;

struct point
{
     long long x;
     long long y;
};

point p[100005];

long long f(point a,point b)
{
     return a.x*b.y-a.y*b.x;
}

int main()
{
     int n;
     int i;
     long long s;
     while(scanf("%d",&n)!=EOF)
     {
          scanf("%lld%lld",&p[1].x,&p[1].y);
          s=0;
          for(i=2;i<=n;i++)
          {
               scanf("%lld%lld",&p[i].x,&p[i].y);
               s=s+f(p[i-1],p[i])%mod;
               s=s%mod;
          }
          s=s+f(p[n],p[1]);
          s=abs(s)%mod;
          cout<<s<<endl;
     }
     return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值