HDOJ3746 Cyclic Nacklace --- KMP求最小循环节

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=3746

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

 

 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

 

 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

 

 

Sample Input

 

3 aaa abca abcde

 

 

Sample Output

0 2 5

 

题意: 给定一个字符串,要求补最少的字符,使得字符串为以某个子串循环至少2次得到的字符串。

题解: 直接用KMP的next数组求出循环节,求出的结果就是字符串应有的最小循环节。

如果判断出已经至少循环2次,就输出0,

否则就判断需要补上多少字符

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
char s[100005];
int Next[100005];
// 求Next数组
void CalNext() {
    Next[0] = 0;
    Next[1] = 0;
    int len = strlen(s);
    int k = 0;// 上次算出的Next值
    for(int i = 2;i <= len;i++) {
        while(s[k] != s[i-1] && k) {
            k = Next[k];
        }
        if(s[k] == s[i-1]) {
            k++;
        }
        Next[i] = k;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--) {
        scanf("%s",s);
        CalNext();
        int len = strlen(s);
        // 求最小循环节长度
        int cicle = len - Next[len];
        if(len % cicle == 0 && (len / cicle > 1)) {
            printf("0\n");
        } else {
            printf("%d\n",cicle-(len%cicle));
        }
        
    }
   
   return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值