E - 05

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.
题意:
谷仓的位置在一条线上,把谷仓分成c份,使谷仓的最小距离最大

分析:
就是用二分

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[100005],c,n;
int vp(long int g)
{
    int i,gr,sum;
    gr=a[0];
    sum=1;
    for(i=1;i<n;i++)
    if(a[i]-gr>=g)
    {
       gr=a[i];
       sum++;
    }
    return sum;
}
int main()
{
    int i,l,k,mid;
    scanf("%d%d",&n,&c);
    for(i=0;i<n;i++)
        scanf("%d",&a[i]);
    sort(a,a+n);
    l=0;
    k=a[n-1]-a[0];
    while(l<=k)
    {
        mid=(k+l)/2;
        if(vp(mid)>=c)l=mid+1;
        else
        if(vp(mid)<c)
            k=mid-1;
    }
    printf("%d\n",l-1);
}

我发现用c++老是超时,必须改成c,主要是c不熟啊难过

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值