ZOJ 3822 Domination【概率dp】

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3822

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

题意:

每天放一个棋子,使得每一行每一列至少一个棋子,问放棋子的天数的期望值

分析:

求出每种天数的概率,最后套用公式

代码:

#include<bits/stdc++.h>
using namespace std;
double dp[2501][51][51];///dp[k][i][j] 表示放k个棋子 占i行 和 j列的概率
int main()
{
    int t;
    int N, M;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &N, &M);
        memset(dp, 0, sizeof(dp));
        dp[0][0][0] = 1;
        double p;
        for(int k = 0; k <= N*M; k++)
        {
            for(int i = 0; i <= N; i++)
            {
                for(int j = 0; j <= M; j++)
                {
                    if(i == N && j == M || dp[k][i][j] == 0) continue;
                    if(i * j >= k)
                        dp[k+1][i][j] += dp[k][i][j] * (i * j - k) / (N * M - k);
                    if(i < N)
                        dp[k+1][i+1][j] += dp[k][i][j] * (N - i) * j / (N * M - k);
                    if(j < M)
                        dp[k+1][i][j+1] += dp[k][i][j] * (M - j) * i / (N * M - k);
                    if(i < N && j < M)
                        dp[k+1][i+1][j+1] += dp[k][i][j] * (N - i) * (M - j) / (N * M - k);
                }
            }
        }
        double ans = 0;
        for(int i = 0; i <= N*M; i++)//求期望,套公式概率*天数的和
            ans += i * dp[i][N][M];
        printf("%.10f\n", ans);
    }
    return 0;
}

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值