String of CCPC【2017年CCPC 秦皇岛】【ZOJ3985】

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3985

BaoBao has just found a string 

To make this string more valuable, BaoBao decides to buy some characters from a character store. Each time he can buy one 'C' or one 'P' from the store, and insert the character into any position in 

The final value BaoBao obtains is the final value of 

Input

There are multiple test cases. The first line of the input contains an integer 

The first line contains an integer 

The second line contains the string 

It's guaranteed that the sum of 

Output

For each test case output one line containing one integer, indicating the maximum final value BaoBao can obtain.

Sample Input

3
3
CCC
5
CCCCP
4
CPCP

Sample Output

1
1
1

Hint

For the first sample test case, BaoBao can buy one 'P' (cost 0 value) and change 

For the second sample test case, BaoBao can buy one 'C' and one 'P' (cost 0 + 1 = 1 value) and change 

For the third sample test case, BaoBao can buy one 'C' (cost 0 value) and change 

It's easy to prove that no strategies of buying and inserting characters can achieve a better result for the sample test cases.

题意:

在一个字符串中可以多次添加C,P,每i次添加需要减去价值(i-1),求最大的价值

分析:

暴力,一个for循环,很简单,但是前后缀和我给弄混了,wrong了8发

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=200010;
int n,m,k;
int a[maxn],sumq[maxn],sumh[maxn];
int c[maxn];
int ans,ct,cnt,tmp,flag;
char s[maxn];
int main()
{
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        ans=0;   flag=1;
        scanf("%s",s);
        int l=strlen(s);
        sumq[0]=0;
        sumh[l]=0;
        for(int i=0;i<l;i++){
           if(i) sumq[i]=sumq[i-1];
           if(i-3>=0&&s[i-3]=='C'&&s[i-2]=='C'&&s[i-1]=='P'&&s[i]=='C')
           {
               sumq[i]++;
           }
        }
        for(int i=l-1;i>=0;i--)
        {
           sumh[i]=sumh[i+1];
           if(i+3>=l)continue;
           if(s[i]=='C'&&s[i+1]=='C'&&s[i+2]=='P'&&s[i+3]=='C')
           {
               sumh[i]++;
           }
        }
        ans=max(sumq[l-1],sumh[0]);
        for(int i=0;i<l;i++)
        {
           if(s[i]=='C'&&s[i+1]=='P'&&s[i+2]=='C'&&i+2<l)
           {
               if(i==0) ans=max(ans,sumh[i]+1);
               else ans=max(ans,sumq[i-1]+sumh[i]+1);
               continue;
           }
           if(s[i-2]=='C'&&s[i-1]=='C'&&s[i]=='C'&&i>=2)
           {
               if(i==2) ans=max(ans,sumh[i]+1);
               else ans=max(ans,sumq[i-1]+sumh[i]+1);
               continue;
           }
           if(s[i-1]=='C'&&s[i]=='P'&&s[i+1]=='C'&&i+1<l&&i-1>=0)
           {
               if(i==0) ans=max(ans,sumh[i]+1);
               else ans=max(ans,sumq[i-1]+sumh[i]+1);
               continue;
           }
           if(s[i-2]=='C'&&s[i-1]=='C'&&s[i]=='P'&&i>=2)
           {
               if(i==2) ans=max(ans,sumh[i]+1);
               else
               ans=max(ans,sumq[i]+sumh[i+1]+1);
               continue;
           }

        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生就业服务平台管理系统按照操作主体分为管理员和用户。管理员的功能包括学生档案管理、字典管理、试卷管理、试卷选题管理、试题表管理、考试记录表管理、答题详情表管理、错题表管理、法律法规管理、法律法规收藏管理、法律法规留言管理、就业分析管理、论坛管理、企业管理、简历管理、老师管理、简历投递管理、新闻资讯管理、新闻资讯收藏管理、新闻资讯留言管理、学生信息管理、宣传管理、学生管理、职位招聘管理、职位收藏管理、招聘咨询管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 大学生就业服务平台管理系统可以提高大学生就业服务平台信息管理问题的解决效率,优化大学生就业服务平台信息处理流程,保证大学生就业服务平台信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理新闻信息,管理大学生就业服务平台信息,包括考试管理,培训管理,投递管理,薪资管理等,可以管理新闻信息。 考试管理界面,管理员在考试管理界面中可以对界面中显示,可以对考试信息的考试状态进行查看,可以添加新的考试信息等。投递管理界面,管理员在投递管理界面中查看投递种类信息,投递描述信息,新增投递信息等。新闻信息管理界面,管理员在新闻信息管理界面中新增新闻信息,可以删除新闻信息。新闻信息类型管理界面,管理员在新闻信息类型管理界面查看新闻信息的工作状态,可以对新闻信息的数据进行导出,可以添加新新闻信息的信息,可以编辑新闻信息信息,删除新闻信息信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值