UVa 270 — Lining Up

``How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input consists of N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. The list of pairs is ended with an end-of-file character. No pair will occur twice.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line. 
The output consists of one integer representing the largest number of points that all lie on one line.

Sample Input

1

1 1
2 2
3 3
9 10
10 11

Sample Output

3
题意:N个点 最多有多少点共线;
分析:暴力就过,主要是在输入时 sscanf较为好用;
代码如下:
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;

struct point{
	double x,y;
}p[800];
int main(){
	int o;
	char c;
	char s[10];
	scanf("%d",&o);
	c=getchar();
	c=getchar();
	while(o--)
        {
           int i=0;//注意每一组数据都需从0开始,存入数组,不可在while(o--)上面初始化,WA在这儿!
            while(gets(s))
            {
                if(!strlen(s))
                    break;
               sscanf(s,"%lf %lf",&p[i].x,&p[i].y);

                i++;
            }
	  int mmax = 0;
        int n=i;
	  for(int i = 0; i < n; ++i)
        {
		  for(int j = i + 1;j < n; ++j)
		  {
			  int s = 2;
			  double a = p[j].x - p[i].x;
			  double b = p[j].y - p[i].y;
			  for(int k = j + 1; k < n; ++k)//若从k=0开始会超时,需注意!
			  {
			     double c = p[k].x - p[j].x;
				 double d = p[k].y - p[j].y;
				 if(a * d == c * b)
					 s++;
			  }
			  if(mmax < s)
				  mmax = s;
		  }
	  }
	  printf("%d\n",mmax);
	  if(o)
        printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值