The summer training of ZJU ICPC in July is about to end. To celebrate this great and happy day, the coaches of ZJU ICPC TeamNavi and Fancy decided to BG everyone! Beside the two coaches, there are N participants. Those participants are divided into four groups to make problems for other groups.
After a brief discussion, they decided to go to Lou Wai Lou and have a great lunch. The cost for each person to have a meal in Lou Wai Lou is W yuan. Though it is very expensive, there is a special discount that Lou Wai Lou provided: for every K persons, one of them can have a free meal.
Navi and Fancy will equally pay all the cost for this great BG. Please help them to calculate how much money they each need to pay. By the way, please take care that the minimum monetary unit of RMB is fen (0.01 yuan).
Input
There are multiple test cases (no more than 100).
For each test case, there is only one line which contains three numbers N (1 <= N <= 100), W (0 <= W <= 10000) and K (1 < = K <= 100).
Output
For each test case, output the money a coach need to pay, rounded into 0.01 yuan.
Sample Input
3 70 3 32 999 1
Sample Output
140.00 0.00注意精度:
code:
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<math.h>
int main()
{
// freopen("i.txt","r",stdin);
int n,k,i;
double w,ans;
while(scanf("%d%lf%d",&n,&w,&k)!=EOF)
{
n+=2;
ans=(n-n/k)*w/2;
printf("%.2lf\n",ans+0.0049);//虽然差了0.0001,0.005会WA,后面加上的数要<0.005;
}
return 0;
}