zoj1383Binary Numbers

Binary Numbers
Time Limit: 2 Seconds      Memory Limit: 65536 KB
Given a positive integer n, print out the positions of all 1's in its binary representation. The position of the least significant bit is 0.




Example


The positions of 1's in the binary representation of 13 are 0, 2, 3.




Task


Write a program which for each data set:


reads a positive integer n,


computes the positions of 1's in the binary representation of n,


writes the result.




Input


The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.


Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.




Output


The output should consists of exactly d lines, one line for each data set.


Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.




Sample Input


1
13




Sample Output


0 2 3


题意:统计一个数的二进制表示中,1所在的位置,注意是从0开始的。我的做法是将1的位置用队列存放了。

#include<stdio.h>
#include<queue>
using namespace std;
int main()
{
	int n,number,i;
	scanf("%d",&n);
	queue<int>q;
	while(n--)
	{
		i=0;
		scanf("%d",&number);
		while(number)
		{
			if(number%2)
				q.push(i);
			number=number/2;
			i++;
		}
		q.push(-1);
	}
	while(!q.empty())
	{
		i=q.front();q.pop();
		if(q.front()!=-1)
			printf("%d ",i);
		else 
		{
			printf("%d\n",i);
			q.pop();
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值