Wireless Network
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
题意描述:已知可以进行两种操作,修复计算机或测试两台计算机之间是否能进行通信,要求回答所测试的操作,如果两台计算机之间可以通信输出SUCCESS,否则输出FAIL。
解题思路:定义一个二维数组来计算两坐标之间的距离,然后判断后面的字符时O还是S,如果是O的话用一个数组来存储O后面的树,S的话判断后面两个数的祖先是否相同,相同输出SUCCESS,否则输出FAIL。
AC代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
int f[1050],n,m;
int b[1050],c[1050],x[1050];
double a[1050][1050];
void init()
{
int i;
for(i=1;i<=n;i++)
f[i]=i;
return;
}
int getf(int v)
{
if(f[v]==v)
return v;
else
{
f[v]=getf(f[v]);
return f[v];
}
}
void merge(int v,int u)
{
int t1,t2;
t1=getf(v);
t2=getf(u);
if(t1!=t2)
f[t2]=t1;
return;
}
int main()
{
int i,j,k=0,y,w,e;
char ch;
while(scanf("%d%d",&n,&m)!=EOF)
{
//每次开始要对a数组和x数组进行清零
memset(a,0,sizeof(a));
memset(x,0,sizeof(x));
init();
for(i=1;i<=n;i++)
scanf("%d%d",&b[i],&c[i]);
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
a[i][j]=sqrt(((b[i]-b[j])*(b[i]-b[j])*1.0)+((c[i]-c[j])*(c[i]-c[j])));//计算两坐标点之间的距离
}
//printf("%lf\n",a[1][2]);
while(scanf(" %c",&ch)!=EOF)
{//printf("%c\n",ch);
if(ch=='O')
{
scanf("%d",&y);
x[++k]=y;//定义一个新的数组存储O后面的数
for(i=1;i<k;i++)
{
if(a[x[i]][x[k]]<=m)//合并的条件(第一个点到最后一个点的距离小于或者等于最大通信距离)
merge(x[i],x[k]);
}
}
if(ch=='S')
{
scanf("%d%d",&w,&e);
if(getf(w)==getf(e))
printf("SUCCESS\n");
else
printf("FAIL\n");
}
}
}
return 0;
}