Wireless Network (并查集)

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

思路

这道题用到了并查集的思想。首先让所有计算机都只指向自己,然后在输入每台计算机的位置(因为这道题是用坐标来表示计算机的,所以开了一个结构体数组来记录)。位置输入完之后就开始,操作语句的输入了,输入O的时候,是修复操作,修复第q台计算机,然后还和计算其他已修复的距离,如果小于通讯的最大距离,则可以通讯。输入S的时候,是测试操作,如果可以通讯,则输出SUCCESS,否则输出FAIL。

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <math.h>

using namespace std;
int n,d,p,q;
char c;
bool u[1111];

struct node
{
    int x,y;
    int pre;
}a[1005];

int Find(int x)
{
    return x==a[x].pre?x:Find(a[x].pre);
}

void join(const node a1,const node a2)
{
    int root1,root2;
    root1=Find(a1.pre);
    root2=Find(a2.pre);
    if(root1!=root2)
    {
        if((a1.x-a2.x)*(a1.x-a2.x)+(a1.y-a2.y)*(a1.y-a2.y)<=d)
            a[root2].pre=root1;
    }
}

int main()
{
    scanf("%d %d",&n,&d);
    for(int i=1;i<=n;++i)
    {
        a[i].pre=i;
    }
    memset(u,false,sizeof(u));
    for(int i=1;i<=n;++i)
    {
        scanf("%d %d",&a[i].x,&a[i].y);
    }
    while(scanf("\n%c",&c)!=EOF)
    {
        if(c=='O')
        {
            scanf("%d",&q);
            u[q]=true;
            for(int i=1;i<=n;++i)//计算q到其他点的距离
            {
                if(u[i]&&i!=q)
                    join(a[i],a[q]);
            }
        }
        else
        {
            scanf("%d %d",&p,&q);
            if(Find(p)==Find(q))
                printf("SUCCESS\n");
            else
                printf("FAIL\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值