1014.排名

题目描述:
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
输入:
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
输出:
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。
样例输入:
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
样例输出:
3
CS003 60
CS001 37
CS004 37
0
1

CS000000000000000002 20

#include <iostream>  
#include <vector>  
#include <string>  
#include <algorithm>  

using namespace std;  

struct Student
{
	string m_number;
	int m_totalscore;
	Student(const string &number = "",int totalscore = 0):
	m_number(number),m_totalscore(totalscore){}

	bool operator()(const Student &lhs,const Student &rhs) const
	{
		if( lhs.m_totalscore != rhs.m_totalscore )
			return lhs.m_totalscore > rhs.m_totalscore;
		else
			return lhs.m_number < rhs.m_number;
	}
};

int main()
{
	int N,M,G;
	vector<int> score;
	vector<Student> stu;

	while(cin >> N && N != 0)
	{
		cin >> M >> G;
		for(int i = 0; i < M; ++i)
		{
			int tmp;
			cin >> tmp;
			score.push_back(tmp);
		}
		string name;
		int total_number;
		for(int i = 0; i < N; ++i)
		{
			int total_score = 0;
			cin >> name >> total_number;
			for(int i = 0; i < total_number; ++i)
			{
				int tmp;
				cin >> tmp;
				total_score += score[tmp - 1];
			}
			if(total_score >= G)
				stu.push_back(Student(name,total_score));
		}
		if(stu.size() != 0)
		{
			cout << stu.size() << endl;
			sort(stu.begin(),stu.end(),Student());
			vector<Student>::iterator it;
			for(it = stu.begin(); it != stu.end(); ++it)
			{
				cout << it->m_number << " " << it->m_totalscore << endl;
			}
		}
		else 
			cout << 0 << endl;
		score.clear();
		stu.clear();
	}
	return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值