hdoj 4786 Fibonacci Tree 【最小生成树&&最大生成树】

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3256    Accepted Submission(s): 1042


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
思路: 连通所有的点,且连通白边的数目须是fibonacci数,可以存在黑边; 先按白到黑排序,计算连通后的最大的白边数目max;然后按黑到白排序,计算连通后的最小的白边数目min;最后判断是否连通以及fibonacci数列里是否有数fib[ i ]满足 min>= fib[ i ] <=max 。
代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define M 100000+10
using namespace std;
struct record
{
	int u,v,w;
}num[M];
int per[M];
int fib[M];
void F()
{
	fib[1]=1;
    fib[2]=1;
	for(int i=3;i<=M;i++)
	{
		fib[i]=fib[i-1]+fib[i-2];
	}
}
bool cmp1(record a,record b)
{
	return a.w>b.w;
}
bool cmp2(record a,record b)
{
	return a.w<b.w;
}
int find(int x)
{
	int r=x;
	while(r!=per[r])
	{
		r=per[r];
	}
	per[x]=r;
	return r;
}
bool join(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		per[fx]=fy;
		return true;
	}
	return false;
}
int main()
{
	int t,i,n,m,k=1;
	memset(fib,0,sizeof(fib));
	F();
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&num[i].u,&num[i].v,&num[i].w);
		}
		sort(num,num+m,cmp1);
		for(i=1;i<=n;i++)
		per[i]=i;
		int max=0;
		for(i=0;i<m;i++)
		{
			if(join(num[i].u,num[i].v))
			{
				if(num[i].w==1)
				max++;
			}
		}
		int min=0;
		sort(num,num+m,cmp2);
		for(i=1;i<=n;i++)
		per[i]=i;
		for(i=0;i<m;i++)
		{
			if(join(num[i].u,num[i].v))
			{
				if(num[i].w==1)
				min++;
			}
		}
	    int	ok=0;
		for(i=1;i<=n;i++)
		{
			if(per[i]==i)
			ok++;
			if(ok>1)
			break;
		}
		printf("Case #%d: ",k++);
		if(ok>1)
		{
			printf("No\n");
			continue;
		}
		ok=0;
		for(i=0;fib[i]<max;i++)
		{
			if(fib[i]>=min&&fib[i]<=max)
			{
				ok=1;
				break;
			}
		}
		if(ok)
		printf("Yes\n");
		else
		printf("No\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值