HDOJ 题目4786 Fibonacci Tree(克鲁斯卡尔)

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2562    Accepted Submission(s): 816


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Source
 

Recommend
We have carefully selected several similar problems for you:   5193  5192  5191  5190  5189 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct s
{
	int u,v,w;
}edge[100100];
int pre[100100],a[100100],n,m;
int cmp1(const void *a,const void *b)
{
	return (*(struct s *)a).w-(*(struct s *)b).w;
}
int cmp2(const void *a,const void *b)
{
	return (*(struct s *)b).w-(*(struct s *)a).w;
}
void init(int n)
{
	int i;
	for(i=0;i<=n;i++)
		pre[i]=i;
}
void fun()
{
	int i;
	a[1]=1;a[2]=2;
	for(i=3;i<100100;i++)
		a[i]=a[i-1]+a[i-2];
}
int find(int x)
{
	if(x==pre[x])
		return pre[x];
	return pre[x]=find(pre[x]);
}
int ku()
{
	init(n);
	int ans=0,i,j;
	for(i=0;i<m;i++)
	{
		int u,v,w;
		u=edge[i].u;
		v=edge[i].v;
		w=edge[i].w;
		int fa=find(u);
		int fb=find(v);
		if(fa!=fb)
		{
			pre[fa]=fb;
			ans+=w;
		}
	}
	int num=0;
	for(i=1;i<=n;i++)
		if(pre[i]==i)
			num++;
		if(num>1)
			return -1;
		return ans;
}
int main()
{
	int t,c=0;
	scanf("%d",&t);
	fun();
	while(t--)
	{
		//int n,m
		int i,l,r;
		scanf("%d%d",&n,&m);
		//init(n);
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
		}
		qsort(edge,m,sizeof(edge[0]),cmp1);
		l=ku();
		qsort(edge,m,sizeof(edge[0]),cmp2);
		r=ku();
		if(l==-1||r==-1)
		{
			printf("Case #%d: No\n",++c);
		}
		else
		{
			int flag=0;
			for(i=1;i<100100;i++)
			{
				if(a[i]>r)
					break;
				if(a[i]<=r&&a[i]>=l)
				{
					printf("Case #%d: Yes\n",++c);
					flag=1;
					break;
				}
			}
			if(!flag)
				printf("Case #%d: No\n",++c);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值