centos7 命令行版本 安装 teamviewer

版权声明: https://blog.csdn.net/longgyy/article/details/79946096

主机没有公网IP的,本来想着通过映射到公网IP解决,但是后面想想,好像用teamviewer也可以远程控制~~于是乎就去官网查看安装包,结果发现centos在安装的时候还不是那么顺利的~~



How to install TeamViewer on RedHat and CentOS

No ratings

To install TeamViewer on CentOS 7 and RedHat Enterprise Linux 7,
a few things have to be considered.

RedHat Enterprise Linux

On RHEL, TeamViewer can currently only be installed with a Workstation or Server subscription. With the RHEL Desktop subscription, not all dependencies (namely qt5-qtdeclarative) can be resolved.
Additionally, the epel repository needs to be enabled.

Required steps:

wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
                                                  # assuming 64bit Workstation
wget https://download.teamviewer.com/download/linux/teamviewer-host.x86_64.rpm
yum install ./epel-release-latest-7.noarch.rpm    # must be installed first
yum install ./teamviewer-host*.rpm

CentOS

On CentOS 7, the epel repository is required.
Required steps:

                                       # assuming 64bit Workstation
wget https://download.teamviewer.com/download/linux/teamviewer-host.x86_64.rpm
yum install epel-release               # must be installed first
yum install ./teamviewer-host*.rpm


上面部分为teamviewer给出的centos与Redhat的安装说明,看得出是缺少了某些依赖包是自带的源没有导致的,所以官方让我们必须先添加epel-release这个源。其实用官网的这三行代码基本能完成安装的。

下面是本人的一些安装过程


1、下载teamviewer-host

wget https://download.teamviewer.com/download/linux/teamviewer-host.x86_64.rpm

2、用官网说明里的链接,先安装源

yum install epel-release               # must be installed first

用    # ll /etc/yum.repos.d/  #可以查看已安装的源

3、安装teamviewer

yum install ./teamviewer-host*.rpm

安装的过程会提示还需要安装依赖包,中[间按两次y允许就行,数量有点多,安装过程稍久~~

[root@localhost ~]# yum install ./teamviewer-host*.rpm
Loaded plugins: fastestmirror
Examining ./teamviewer-host.x86_64.rpm: teamviewer-host-13.1.1548-0.x86_64
Marking ./teamviewer-host.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package teamviewer-host.x86_64 0:13.1.1548-0 will be installed
--> Processing Dependency: qt5-qtdeclarative >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
epel/x86_64/metalink                                                                |  17 kB  00:00:00     
epel                                                                                | 4.7 kB  00:00:00     
(1/3): epel/x86_64/group_gz                                                         | 266 kB  00:00:00     
(2/3): epel/x86_64/updateinfo                                                       | 908 kB  00:00:07     
(3/3): epel/x86_64/primary_db                                                       | 6.3 MB  00:00:17     
Loading mirror speeds from cached hostfile
 * base: mirror.csclub.uwaterloo.ca
 * epel: mirror.csclub.uwaterloo.ca
 * extras: centos.bhs.mirrors.ovh.net
 * updates: mirror.csclub.uwaterloo.ca
--> Processing Dependency: qt5-qtquickcontrols >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5DBus.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5Gui.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5Qml.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5Quick.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5WebKit.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5Widgets.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Processing Dependency: libQt5X11Extras.so.5()(64bit) >= 5.2 for package: teamviewer-host-13.1.1548-0.x86_64
--> Running transaction check
---> Package qt5-qtbase.x86_64 0:5.6.2-1.el7 will be installed
--> Processing Dependency: qt5-qtbase-common = 5.6.2-1.el7 for package: qt5-qtbase-5.6.2-1.el7.x86_64
--> Processing Dependency: libsystemd.so.0(LIBSYSTEMD_209)(64bit) for package: qt5-qtbase-5.6.2-1.el7.x86_64
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: qt5-qtbase-5.6.2-1.el7.x86_64
--> Processing Dependency: libsystemd.so.0()(64bit) for package: qt5-qtbase-5.6.2-1.el7.x86_64
--> Processing Dependency: libicuuc.so.50()(64bit) for package: qt5-qtbase-5.6.2-1.el7.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: qt5-qtbase-5.6.2-1.el7.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: qt5-qtbase-5.6.2-1.el7.x86_64
---> Package qt5-qtbase-gui.x86_64 0:5.6.2-1.el7 will be installed
--> Processing Dependency: libpng15.so.15(PNG15_0)(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: glx-utils for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-xkb.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-xinerama.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-xfixes.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-sync.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-shm.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-shape.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-render.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-render-util.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-randr.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-keysyms.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-image.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-icccm.so.4()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libxcb-glx.so.0()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libpng15.so.15()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libjpeg.so.62()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libgbm.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libfontconfig.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libcups.so.2()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libXrender.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libXi.so.6()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libXext.so.6()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libX11-xcb.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libSM.so.6()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libICE.so.6()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libGL.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
--> Processing Dependency: libEGL.so.1()(64bit) for package: qt5-qtbase-gui-5.6.2-1.el7.x86_64
---> Package qt5-qtdeclarative.x86_64 0:5.6.2-1.el7 will be installed
--> Processing Dependency: libQt5XmlPatterns.so.5(Qt_5)(64bit) for package: qt5-qtdeclarative-5.6.2-1.el7.x86_64
--> Processing Dependency: libQt5XmlPatterns.so.5()(64bit) for package: qt5-qtdeclarative-5.6.2-1.el7.x86_64
---> Package qt5-qtquickcontrols.x86_64 0:5.6.2-1.el7 will be installed
---> Package qt5-qtwebkit.x86_64 0:5.6.2-1.el7 will be installed
--> Processing Dependency: libQt5Positioning.so.5(Qt_5)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libQt5Sensors.so.5(Qt_5)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libQt5WebChannel.so.5(Qt_5)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.1.9)(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libQt5Positioning.so.5()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libQt5Sensors.so.5()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libQt5WebChannel.so.5()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libXcomposite.so.1()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libgstapp-0.10.so.0()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libgstbase-0.10.so.0()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libgstinterfaces-0.10.so.0()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libgstpbutils-0.10.so.0()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libgstreamer-0.10.so.0()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libgstvideo-0.10.so.0()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libwebp.so.4()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: qt5-qtwebkit-5.6.2-1.el7.x86_64
---> Package qt5-qtx11extras.x86_64 0:5.6.2-1.el7 will be installed
--> Running transaction check
---> Package cups-libs.x86_64 1:1.6.3-29.el7 will be installed
---> Package fontconfig.x86_64 0:2.10.95-11.el7 will be installed
--> Processing Dependency: fontpackages-filesystem for package: fontconfig-2.10.95-11.el7.x86_64
--> Processing Dependency: font(:lang=en) for package: fontconfig-2.10.95-11.el7.x86_64
---> Package glx-utils.x86_64 0:8.2.0-3.el7 will be installed
---> Package gstreamer.x86_64 0:0.10.36-7.el7 will be installed
--> Processing Dependency: gstreamer-tools >= 0.10.36 for package: gstreamer-0.10.36-7.el7.x86_64
---> Package gstreamer-plugins-base.x86_64 0:0.10.36-10.el7 will be installed
--> Processing Dependency: libtheoraenc.so.1(libtheoraenc_1.0)(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libtheoradec.so.1(libtheoradec_1.0)(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: iso-codes for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libvorbisenc.so.2()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libvorbis.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libvisual-0.4.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libtheoraenc.so.1()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libtheoradec.so.1()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libpangocairo-1.0.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libpango-1.0.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: liborc-test-0.4.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: liborc-0.4.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libogg.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libcdda_paranoia.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libcdda_interface.so.0()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libcairo.so.2()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
--> Processing Dependency: libXv.so.1()(64bit) for package: gstreamer-plugins-base-0.10.36-10.el7.x86_64
---> Package libICE.x86_64 0:1.0.9-9.el7 will be installed
---> Package libSM.x86_64 0:1.2.2-2.el7 will be installed
---> Package libX11.x86_64 0:1.6.5-1.el7 will be installed
--> Processing Dependency: libX11-common >= 1.6.5-1.el7 for package: libX11-1.6.5-1.el7.x86_64
---> Package libXcomposite.x86_64 0:0.4.4-4.1.el7 will be installed
---> Package libXext.x86_64 0:1.3.3-3.el7 will be installed
---> Package libXi.x86_64 0:1.7.9-1.el7 will be installed
---> Package libXrender.x86_64 0:0.9.10-1.el7 will be installed
---> Package libicu.x86_64 0:50.1.2-15.el7 will be installed
---> Package libjpeg-turbo.x86_64 0:1.2.90-5.el7 will be installed
---> Package libpng.x86_64 2:1.5.13-7.el7_2 will be installed
---> Package libwebp.x86_64 0:0.3.0-7.el7 will be installed
---> Package libxcb.x86_64 0:1.12-1.el7 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.12-1.el7.x86_64
---> Package libxslt.x86_64 0:1.1.28-5.el7 will be installed
---> Package mesa-libEGL.x86_64 0:17.0.1-6.20170307.el7 will be installed
--> Processing Dependency: libxshmfence.so.1()(64bit) for package: mesa-libEGL-17.0.1-6.20170307.el7.x86_64
---> Package mesa-libGL.x86_64 0:17.0.1-6.20170307.el7 will be installed
--> Processing Dependency: mesa-libglapi = 17.0.1-6.20170307.el7 for package: mesa-libGL-17.0.1-6.20170307.el7.x86_64
--> Processing Dependency: libglapi.so.0()(64bit) for package: mesa-libGL-17.0.1-6.20170307.el7.x86_64
--> Processing Dependency: libXxf86vm.so.1()(64bit) for package: mesa-libGL-17.0.1-6.20170307.el7.x86_64
--> Processing Dependency: libXfixes.so.3()(64bit) for package: mesa-libGL-17.0.1-6.20170307.el7.x86_64
--> Processing Dependency: libXdamage.so.1()(64bit) for package: mesa-libGL-17.0.1-6.20170307.el7.x86_64
---> Package mesa-libgbm.x86_64 0:17.0.1-6.20170307.el7 will be installed
---> Package openssl-libs.x86_64 1:1.0.1e-34.el7 will be updated
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-34.el7 for package: 1:openssl-1.0.1e-34.el7.x86_64
---> Package openssl-libs.x86_64 1:1.0.2k-8.el7 will be an update
---> Package qt5-qtbase-common.noarch 0:5.6.2-1.el7 will be installed
---> Package qt5-qtlocation.x86_64 0:5.6.2-1.el7 will be installed
---> Package qt5-qtsensors.x86_64 0:5.6.2-1.el7 will be installed
---> Package qt5-qtwebchannel.x86_64 0:5.6.2-1.el7 will be installed
---> Package qt5-qtxmlpatterns.x86_64 0:5.6.2-1.el7 will be installed
---> Package systemd-libs.x86_64 0:208-11.el7 will be updated
--> Processing Dependency: systemd-libs = 208-11.el7 for package: systemd-208-11.el7.x86_64
---> Package systemd-libs.x86_64 0:219-42.el7_4.10 will be an update
---> Package xcb-util-image.x86_64 0:0.4.0-2.el7 will be installed
--> Processing Dependency: libxcb-util.so.1()(64bit) for package: xcb-util-image-0.4.0-2.el7.x86_64
---> Package xcb-util-keysyms.x86_64 0:0.4.0-1.el7 will be installed
---> Package xcb-util-renderutil.x86_64 0:0.3.9-3.el7 will be installed
---> Package xcb-util-wm.x86_64 0:0.4.1-5.el7 will be installed
--> Running transaction check
---> Package cairo.x86_64 0:1.14.8-2.el7 will be installed
--> Processing Dependency: libpixman-1.so.0()(64bit) for package: cairo-1.14.8-2.el7.x86_64
---> Package cdparanoia-libs.x86_64 0:10.2-17.el7 will be installed
---> Package fontpackages-filesystem.noarch 0:1.44-8.el7 will be installed
---> Package gstreamer-tools.x86_64 0:0.10.36-7.el7 will be installed
---> Package iso-codes.noarch 0:3.46-2.el7 will be installed
--> Processing Dependency: xml-common for package: iso-codes-3.46-2.el7.noarch
---> Package libX11-common.noarch 0:1.6.5-1.el7 will be installed
---> Package libXau.x86_64 0:1.0.8-2.1.el7 will be installed
---> Package libXdamage.x86_64 0:1.1.4-4.1.el7 will be installed
---> Package libXfixes.x86_64 0:5.0.3-1.el7 will be installed
---> Package libXv.x86_64 0:1.0.11-1.el7 will be installed
---> Package libXxf86vm.x86_64 0:1.1.4-1.el7 will be installed
---> Package libogg.x86_64 2:1.3.0-7.el7 will be installed
---> Package libtheora.x86_64 1:1.1.1-8.el7 will be installed
---> Package libvisual.x86_64 0:0.4.0-16.el7 will be installed
---> Package libvorbis.x86_64 1:1.3.3-8.el7 will be installed
---> Package libxshmfence.x86_64 0:1.2-1.el7 will be installed
---> Package lyx-fonts.noarch 0:2.2.3-1.el7 will be installed
---> Package mesa-libglapi.x86_64 0:17.0.1-6.20170307.el7 will be installed
---> Package openssl.x86_64 1:1.0.1e-34.el7 will be updated
---> Package openssl.x86_64 1:1.0.2k-8.el7 will be an update
---> Package orc.x86_64 0:0.4.26-1.el7 will be installed
---> Package pango.x86_64 0:1.40.4-1.el7 will be installed
--> Processing Dependency: libthai(x86-64) >= 0.1.9 for package: pango-1.40.4-1.el7.x86_64
--> Processing Dependency: libXft(x86-64) >= 2.0.0 for package: pango-1.40.4-1.el7.x86_64
--> Processing Dependency: harfbuzz(x86-64) >= 1.0.3 for package: pango-1.40.4-1.el7.x86_64
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: pango-1.40.4-1.el7.x86_64
--> Processing Dependency: libthai.so.0()(64bit) for package: pango-1.40.4-1.el7.x86_64
--> Processing Dependency: libharfbuzz.so.0()(64bit) for package: pango-1.40.4-1.el7.x86_64
--> Processing Dependency: libXft.so.2()(64bit) for package: pango-1.40.4-1.el7.x86_64
---> Package systemd.x86_64 0:208-11.el7 will be updated
--> Processing Dependency: systemd = 208-11.el7 for package: systemd-sysv-208-11.el7.x86_64
--> Processing Dependency: systemd = 208-11.el7 for package: libgudev1-208-11.el7.x86_64
---> Package systemd.x86_64 0:219-42.el7_4.10 will be an update
--> Processing Dependency: kmod >= 18-4 for package: systemd-219-42.el7_4.10.x86_64
---> Package xcb-util.x86_64 0:0.4.0-2.el7 will be installed
--> Running transaction check
---> Package harfbuzz.x86_64 0:1.3.2-1.el7 will be installed
--> Processing Dependency: libgraphite2.so.3()(64bit) for package: harfbuzz-1.3.2-1.el7.x86_64
---> Package kmod.x86_64 0:14-9.el7 will be updated
---> Package kmod.x86_64 0:20-15.el7_4.7 will be an update
---> Package libXft.x86_64 0:2.3.2-2.el7 will be installed
---> Package libgudev1.x86_64 0:208-11.el7 will be updated
---> Package libgudev1.x86_64 0:219-42.el7_4.10 will be an update
--> Processing Dependency: glib2 >= 2.42 for package: libgudev1-219-42.el7_4.10.x86_64
---> Package libthai.x86_64 0:0.1.14-9.el7 will be installed
---> Package pixman.x86_64 0:0.34.0-1.el7 will be installed
---> Package systemd-sysv.x86_64 0:208-11.el7 will be updated
---> Package systemd-sysv.x86_64 0:219-42.el7_4.10 will be an update
---> Package xml-common.noarch 0:0.6.3-39.el7 will be installed
--> Running transaction check
---> Package glib2.x86_64 0:2.36.3-5.el7 will be updated
---> Package glib2.x86_64 0:2.50.3-3.el7 will be an update
---> Package graphite2.x86_64 0:1.3.10-1.el7_3 will be installed
--> Processing Conflict: systemd-219-42.el7_4.10.x86_64 conflicts initscripts < 9.49.28-1
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package initscripts.x86_64 0:9.49.17-1.el7 will be updated
---> Package initscripts.x86_64 0:9.49.39-1.el7_4.1 will be an update
--> Processing Conflict: systemd-219-42.el7_4.10.x86_64 conflicts dracut < 033-499
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package dracut.x86_64 0:033-161.el7 will be updated
--> Processing Dependency: dracut = 033-161.el7 for package: dracut-config-rescue-033-161.el7.x86_64
--> Processing Dependency: dracut = 033-161.el7 for package: dracut-network-033-161.el7.x86_64
---> Package dracut.x86_64 0:033-502.el7_4.1 will be an update
--> Running transaction check
---> Package dracut-config-rescue.x86_64 0:033-161.el7 will be updated
---> Package dracut-config-rescue.x86_64 0:033-502.el7_4.1 will be an update
---> Package dracut-network.x86_64 0:033-161.el7 will be updated
---> Package dracut-network.x86_64 0:033-502.el7_4.1 will be an update
--> Finished Dependency Resolution


Dependencies Resolved


===========================================================================================================
 Package                      Arch        Version                       Repository                    Size
===========================================================================================================
Installing:
 teamviewer-host              x86_64      13.1.1548-0                   /teamviewer-host.x86_64       50 M
Updating:
 dracut                       x86_64      033-502.el7_4.1               updates                      321 k
 initscripts                  x86_64      9.49.39-1.el7_4.1             updates                      435 k
Installing for dependencies:
 cairo                        x86_64      1.14.8-2.el7                  base                         713 k
 cdparanoia-libs              x86_64      10.2-17.el7                   base                          56 k
 cups-libs                    x86_64      1:1.6.3-29.el7                base                         356 k
 fontconfig                   x86_64      2.10.95-11.el7                base                         229 k
 fontpackages-filesystem      noarch      1.44-8.el7                    base                         9.9 k
 glx-utils                    x86_64      8.2.0-3.el7                   base                          32 k
 graphite2                    x86_64      1.3.10-1.el7_3                updates                      115 k
 gstreamer                    x86_64      0.10.36-7.el7                 base                         958 k
 gstreamer-plugins-base       x86_64      0.10.36-10.el7                base                         1.2 M
 gstreamer-tools              x86_64      0.10.36-7.el7                 base                          27 k
 harfbuzz                     x86_64      1.3.2-1.el7                   base                         177 k
 iso-codes                    noarch      3.46-2.el7                    base                         2.7 M
 libICE                       x86_64      1.0.9-9.el7                   base                          66 k
 libSM                        x86_64      1.2.2-2.el7                   base                          39 k
 libX11                       x86_64      1.6.5-1.el7                   base                         606 k
 libX11-common                noarch      1.6.5-1.el7                   base                         164 k
 libXau                       x86_64      1.0.8-2.1.el7                 base                          29 k
 libXcomposite                x86_64      0.4.4-4.1.el7                 base                          22 k
 libXdamage                   x86_64      1.1.4-4.1.el7                 base                          20 k
 libXext                      x86_64      1.3.3-3.el7                   base                          39 k
 libXfixes                    x86_64      5.0.3-1.el7                   base                          18 k
 libXft                       x86_64      2.3.2-2.el7                   base                          58 k
 libXi                        x86_64      1.7.9-1.el7                   base                          40 k
 libXrender                   x86_64      0.9.10-1.el7                  base                          26 k
 libXv                        x86_64      1.0.11-1.el7                  base                          18 k
 libXxf86vm                   x86_64      1.1.4-1.el7                   base                          18 k
 libicu                       x86_64      50.1.2-15.el7                 base                         6.9 M
 libjpeg-turbo                x86_64      1.2.90-5.el7                  base                         134 k
 libogg                       x86_64      2:1.3.0-7.el7                 base                          24 k
 libpng                       x86_64      2:1.5.13-7.el7_2              base                         213 k
 libthai                      x86_64      0.1.14-9.el7                  base                         187 k
 libtheora                    x86_64      1:1.1.1-8.el7                 base                         136 k
 libvisual                    x86_64      0.4.0-16.el7                  base                         138 k
 libvorbis                    x86_64      1:1.3.3-8.el7                 base                         204 k
 libwebp                      x86_64      0.3.0-7.el7                   base                         170 k
 libxcb                       x86_64      1.12-1.el7                    base                         211 k
 libxshmfence                 x86_64      1.2-1.el7                     base                         7.2 k
 libxslt                      x86_64      1.1.28-5.el7                  base                         242 k
 lyx-fonts                    noarch      2.2.3-1.el7                   epel                         159 k
 mesa-libEGL                  x86_64      17.0.1-6.20170307.el7         base                          82 k
 mesa-libGL                   x86_64      17.0.1-6.20170307.el7         base                         155 k
 mesa-libgbm                  x86_64      17.0.1-6.20170307.el7         base                          32 k
 mesa-libglapi                x86_64      17.0.1-6.20170307.el7         base                          41 k
 orc                          x86_64      0.4.26-1.el7                  base                         166 k
 pango                        x86_64      1.40.4-1.el7                  base                         275 k
 pixman                       x86_64      0.34.0-1.el7                  base                         248 k
 qt5-qtbase                   x86_64      5.6.2-1.el7                   base                         2.9 M
 qt5-qtbase-common            noarch      5.6.2-1.el7                   base                          25 k
 qt5-qtbase-gui               x86_64      5.6.2-1.el7                   base                         5.4 M
 qt5-qtdeclarative            x86_64      5.6.2-1.el7                   base                         4.3 M
 qt5-qtlocation               x86_64      5.6.2-1.el7                   base                         718 k
 qt5-qtquickcontrols          x86_64      5.6.2-1.el7                   base                         926 k
 qt5-qtsensors                x86_64      5.6.2-1.el7                   base                         195 k
 qt5-qtwebchannel             x86_64      5.6.2-1.el7                   base                          81 k
 qt5-qtwebkit                 x86_64      5.6.2-1.el7                   epel                          10 M
 qt5-qtx11extras              x86_64      5.6.2-1.el7                   base                          25 k
 qt5-qtxmlpatterns            x86_64      5.6.2-1.el7                   base                         1.1 M
 xcb-util                     x86_64      0.4.0-2.el7                   base                          16 k
 xcb-util-image               x86_64      0.4.0-2.el7                   base                          15 k
 xcb-util-keysyms             x86_64      0.4.0-1.el7                   base                          10 k
 xcb-util-renderutil          x86_64      0.3.9-3.el7                   base                          12 k
 xcb-util-wm                  x86_64      0.4.1-5.el7                   base                          25 k
 xml-common                   noarch      0.6.3-39.el7                  base                          26 k
Updating for dependencies:
 dracut-config-rescue         x86_64      033-502.el7_4.1               updates                       56 k
 dracut-network               x86_64      033-502.el7_4.1               updates                       98 k
 glib2                        x86_64      2.50.3-3.el7                  base                         2.3 M
 kmod                         x86_64      20-15.el7_4.7                 updates                      121 k
 libgudev1                    x86_64      219-42.el7_4.10               updates                       85 k
 openssl                      x86_64      1:1.0.2k-8.el7                base                         492 k
 openssl-libs                 x86_64      1:1.0.2k-8.el7                base                         1.2 M
 systemd                      x86_64      219-42.el7_4.10               updates                      5.2 M
 systemd-libs                 x86_64      219-42.el7_4.10               updates                      378 k
 systemd-sysv                 x86_64      219-42.el7_4.10               updates                       72 k


Transaction Summary
===========================================================================================================
Install  1 Package  (+63 Dependent packages)
Upgrade  2 Packages (+10 Dependent packages)


Total size: 104 M
Total download size: 54 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/75): cdparanoia-libs-10.2-17.el7.x86_64.rpm                                      |  56 kB  00:00:21     
(2/75): cups-libs-1.6.3-29.el7.x86_64.rpm                                           | 356 kB  00:00:26     
(3/75): cairo-1.14.8-2.el7.x86_64.rpm                                               | 713 kB  00:00:36     
(4/75): fontconfig-2.10.95-11.el7.x86_64.rpm                                        | 229 kB  00:00:03     
(5/75): fontpackages-filesystem-1.44-8.el7.noarch.rpm                               | 9.9 kB  00:00:00     
(6/75): glx-utils-8.2.0-3.el7.x86_64.rpm                                            |  32 kB  00:00:00     
(7/75): glib2-2.50.3-3.el7.x86_64.rpm                                               | 2.3 MB  00:00:34     
(8/75): dracut-config-rescue-033-502.el7_4.1.x86_64.rpm                             |  56 kB  00:00:56     
(9/75): dracut-network-033-502.el7_4.1.x86_64.rpm                                   |  98 kB  00:00:38     
dracut-033-502.el7_4.1.x86_64. FAILED                                          
http://mirror.csclub.uwaterloo.ca/centos/7.4.1708/updates/x86_64/Packages/dracut-033-502.el7_4.1.x86_64.rpm: [Errno 12] Timeout on http://mirror.csclub.uwaterloo.ca/centos/7.4.1708/updates/x86_64/Packages/dracut-033-502.el7_4.1.x86_64.rpm: (28, 'Resolving timed out after 34212 milliseconds')
Trying other mirror.
(10/75): gstreamer-0.10.36-7.el7.x86_64.rpm                                         | 958 kB  00:00:00     
(11/75): graphite2-1.3.10-1.el7_3.x86_64.rpm                                        | 115 kB  00:00:01     
(12/75): initscripts-9.49.39-1.el7_4.1.x86_64.rpm                                   | 435 kB  00:00:00     
(13/75): gstreamer-tools-0.10.36-7.el7.x86_64.rpm                                   |  27 kB  00:00:00     
(14/75): libICE-1.0.9-9.el7.x86_64.rpm                                              |  66 kB  00:00:00     
(15/75): kmod-20-15.el7_4.7.x86_64.rpm                                              | 121 kB  00:00:00     
(16/75): libSM-1.2.2-2.el7.x86_64.rpm                                               |  39 kB  00:00:01     
(17/75): harfbuzz-1.3.2-1.el7.x86_64.rpm                                            | 177 kB  00:00:02     
(18/75): libXau-1.0.8-2.1.el7.x86_64.rpm                                            |  29 kB  00:00:01     
(19/75): gstreamer-plugins-base-0.10.36-10.el7.x86_64.rpm                           | 1.2 MB  00:00:06     
(20/75): libX11-common-1.6.5-1.el7.noarch.rpm                                       | 164 kB  00:00:04     
(21/75): libXcomposite-0.4.4-4.1.el7.x86_64.rpm                                     |  22 kB  00:00:01     
(22/75): libXext-1.3.3-3.el7.x86_64.rpm                                             |  39 kB  00:00:00     
(23/75): libXft-2.3.2-2.el7.x86_64.rpm                                              |  58 kB  00:00:00     
(24/75): libXfixes-5.0.3-1.el7.x86_64.rpm                                           |  18 kB  00:00:00     
(25/75): libXi-1.7.9-1.el7.x86_64.rpm                                               |  40 kB  00:00:01     
(26/75): libXrender-0.9.10-1.el7.x86_64.rpm                                         |  26 kB  00:00:01     
(27/75): libXv-1.0.11-1.el7.x86_64.rpm                                              |  18 kB  00:00:00     
(28/75): libXxf86vm-1.1.4-1.el7.x86_64.rpm                                          |  18 kB  00:00:00     
(29/75): iso-codes-3.46-2.el7.noarch.rpm                                            | 2.7 MB  00:00:09     
(30/75): libX11-1.6.5-1.el7.x86_64.rpm                                              | 606 kB  00:00:07     
(31/75): libgudev1-219-42.el7_4.10.x86_64.rpm                                       |  85 kB  00:00:00     
(32/75): libogg-1.3.0-7.el7.x86_64.rpm                                              |  24 kB  00:00:02     
(33/75): libXdamage-1.1.4-4.1.el7.x86_64.rpm                                        |  20 kB  00:00:05     
(34/75): libjpeg-turbo-1.2.90-5.el7.x86_64.rpm                                      | 134 kB  00:00:02     
(35/75): libtheora-1.1.1-8.el7.x86_64.rpm                                           | 136 kB  00:00:00     
(36/75): libvorbis-1.3.3-8.el7.x86_64.rpm                                           | 204 kB  00:00:00     
(37/75): libwebp-0.3.0-7.el7.x86_64.rpm                                             | 170 kB  00:00:00     
(38/75): libthai-0.1.14-9.el7.x86_64.rpm                                            | 187 kB  00:00:01     
(39/75): libxcb-1.12-1.el7.x86_64.rpm                                               | 211 kB  00:00:00     
(40/75): libxshmfence-1.2-1.el7.x86_64.rpm                                          | 7.2 kB  00:00:00     
(41/75): libvisual-0.4.0-16.el7.x86_64.rpm                                          | 138 kB  00:00:03     
(42/75): libxslt-1.1.28-5.el7.x86_64.rpm                                            | 242 kB  00:00:01     
(43/75): libpng-1.5.13-7.el7_2.x86_64.rpm                                           | 213 kB  00:00:03     
(44/75): mesa-libGL-17.0.1-6.20170307.el7.x86_64.rpm                                | 155 kB  00:00:00     
(45/75): mesa-libglapi-17.0.1-6.20170307.el7.x86_64.rpm                             |  41 kB  00:00:00     
(46/75): mesa-libEGL-17.0.1-6.20170307.el7.x86_64.rpm                               |  82 kB  00:00:01     
(47/75): mesa-libgbm-17.0.1-6.20170307.el7.x86_64.rpm                               |  32 kB  00:00:01     
(48/75): openssl-1.0.2k-8.el7.x86_64.rpm                                            | 492 kB  00:00:00     
(49/75): pango-1.40.4-1.el7.x86_64.rpm                                              | 275 kB  00:00:00     
(50/75): pixman-0.34.0-1.el7.x86_64.rpm                                             | 248 kB  00:00:00     
warning: /var/cache/yum/x86_64/7/epel/packages/lyx-fonts-2.2.3-1.el7.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY
Public key for lyx-fonts-2.2.3-1.el7.noarch.rpm is not installed
(51/75): lyx-fonts-2.2.3-1.el7.noarch.rpm                                           | 159 kB  00:00:01     
(52/75): orc-0.4.26-1.el7.x86_64.rpm                                                | 166 kB  00:00:00     
(53/75): qt5-qtbase-common-5.6.2-1.el7.noarch.rpm                                   |  25 kB  00:00:00     
(54/75): openssl-libs-1.0.2k-8.el7.x86_64.rpm                                       | 1.2 MB  00:00:01     
(55/75): qt5-qtbase-5.6.2-1.el7.x86_64.rpm                                          | 2.9 MB  00:00:00     
(56/75): qt5-qtquickcontrols-5.6.2-1.el7.x86_64.rpm                                 | 926 kB  00:00:00     
(57/75): qt5-qtsensors-5.6.2-1.el7.x86_64.rpm                                       | 195 kB  00:00:00     
(58/75): qt5-qtwebchannel-5.6.2-1.el7.x86_64.rpm                                    |  81 kB  00:00:00     
(59/75): qt5-qtlocation-5.6.2-1.el7.x86_64.rpm                                      | 718 kB  00:00:00     
(60/75): qt5-qtx11extras-5.6.2-1.el7.x86_64.rpm                                     |  25 kB  00:00:00     
(61/75): qt5-qtxmlpatterns-5.6.2-1.el7.x86_64.rpm                                   | 1.1 MB  00:00:00     
(62/75): libicu-50.1.2-15.el7.x86_64.rpm                                            | 6.9 MB  00:00:11     
(63/75): systemd-libs-219-42.el7_4.10.x86_64.rpm                                    | 378 kB  00:00:00     
(64/75): systemd-sysv-219-42.el7_4.10.x86_64.rpm                                    |  72 kB  00:00:00     
(65/75): xcb-util-0.4.0-2.el7.x86_64.rpm                                            |  16 kB  00:00:00     
(66/75): xcb-util-image-0.4.0-2.el7.x86_64.rpm                                      |  15 kB  00:00:00     
(67/75): xcb-util-keysyms-0.4.0-1.el7.x86_64.rpm                                    |  10 kB  00:00:00     
(68/75): xcb-util-renderutil-0.3.9-3.el7.x86_64.rpm                                 |  12 kB  00:00:00     
(69/75): xcb-util-wm-0.4.1-5.el7.x86_64.rpm                                         |  25 kB  00:00:00     
(70/75): xml-common-0.6.3-39.el7.noarch.rpm                                         |  26 kB  00:00:00     
(71/75): dracut-033-502.el7_4.1.x86_64.rpm                                          | 321 kB  00:00:00     
(72/75): qt5-qtdeclarative-5.6.2-1.el7.x86_64.rpm                                   | 4.3 MB  00:00:05     
(73/75): systemd-219-42.el7_4.10.x86_64.rpm                                         | 5.2 MB  00:00:05     
(74/75): qt5-qtwebkit-5.6.2-1.el7.x86_64.rpm                                        |  10 MB  00:00:09     
(75/75): qt5-qtbase-gui-5.6.2-1.el7.x86_64.rpm                                      | 5.4 MB  00:00:14     
-----------------------------------------------------------------------------------------------------------
Total                                                                      229 kB/s |  54 MB  00:04:00     
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
Importing GPG key 0x352C64E5:
 Userid     : "Fedora EPEL (7) <epel@fedoraproject.org>"
 Fingerprint: 91e9 7d7c 4a5e 96f1 7f3e 888f 6a2f aea2 352c 64e5
 Package    : epel-release-7-9.noarch (@extras)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : glib2-2.50.3-3.el7.x86_64                                                              1/88 
  Updating   : systemd-libs-219-42.el7_4.10.x86_64                                                    2/88 
  Updating   : dracut-033-502.el7_4.1.x86_64                                                          3/88 
  Updating   : kmod-20-15.el7_4.7.x86_64                                                              4/88 
  Updating   : systemd-219-42.el7_4.10.x86_64                                                         5/88 
warning: /etc/rc.d/rc.local created as /etc/rc.d/rc.local.rpmnew
  Updating   : 1:openssl-libs-1.0.2k-8.el7.x86_64                                                     6/88 
  Installing : 2:libogg-1.3.0-7.el7.x86_64                                                            7/88 
  Installing : 2:libpng-1.5.13-7.el7_2.x86_64                                                         8/88 
  Installing : libxshmfence-1.2-1.el7.x86_64                                                          9/88 
  Installing : fontpackages-filesystem-1.44-8.el7.noarch                                             10/88 
  Installing : libjpeg-turbo-1.2.90-5.el7.x86_64                                                     11/88 
  Installing : libICE-1.0.9-9.el7.x86_64                                                             12/88 
  Installing : libicu-50.1.2-15.el7.x86_64                                                           13/88 
  Installing : qt5-qtbase-common-5.6.2-1.el7.noarch                                                  14/88 
  Installing : qt5-qtbase-5.6.2-1.el7.x86_64                                                         15/88 
  Installing : mesa-libglapi-17.0.1-6.20170307.el7.x86_64                                            16/88 
  Installing : mesa-libgbm-17.0.1-6.20170307.el7.x86_64                                              17/88 
  Installing : qt5-qtxmlpatterns-5.6.2-1.el7.x86_64                                                  18/88 
  Installing : libSM-1.2.2-2.el7.x86_64                                                              19/88 
  Installing : lyx-fonts-2.2.3-1.el7.noarch                                                          20/88 
  Installing : fontconfig-2.10.95-11.el7.x86_64                                                      21/88 
  Installing : 1:libtheora-1.1.1-8.el7.x86_64                                                        22/88 
  Installing : 1:libvorbis-1.3.3-8.el7.x86_64                                                        23/88 
  Installing : 1:cups-libs-1.6.3-29.el7.x86_64                                                       24/88 
  Installing : gstreamer-tools-0.10.36-7.el7.x86_64                                                  25/88 
  Installing : gstreamer-0.10.36-7.el7.x86_64                                                        26/88 
  Installing : xml-common-0.6.3-39.el7.noarch                                                        27/88 
  Installing : iso-codes-3.46-2.el7.noarch                                                           28/88 
  Installing : libwebp-0.3.0-7.el7.x86_64                                                            29/88 
  Installing : libthai-0.1.14-9.el7.x86_64                                                           30/88 
  Installing : libX11-common-1.6.5-1.el7.noarch                                                      31/88 
  Installing : libxslt-1.1.28-5.el7.x86_64                                                           32/88 
  Installing : libvisual-0.4.0-16.el7.x86_64                                                         33/88 
  Installing : cdparanoia-libs-10.2-17.el7.x86_64                                                    34/88 
  Installing : graphite2-1.3.10-1.el7_3.x86_64                                                       35/88 
  Installing : harfbuzz-1.3.2-1.el7.x86_64                                                           36/88 
  Installing : pixman-0.34.0-1.el7.x86_64                                                            37/88 
  Installing : libXau-1.0.8-2.1.el7.x86_64                                                           38/88 
  Installing : libxcb-1.12-1.el7.x86_64                                                              39/88 
  Installing : libX11-1.6.5-1.el7.x86_64                                                             40/88 
  Installing : libXext-1.3.3-3.el7.x86_64                                                            41/88 
  Installing : libXrender-0.9.10-1.el7.x86_64                                                        42/88 
  Installing : libXfixes-5.0.3-1.el7.x86_64                                                          43/88 
  Installing : mesa-libEGL-17.0.1-6.20170307.el7.x86_64                                              44/88 
  Installing : libXdamage-1.1.4-4.1.el7.x86_64                                                       45/88 
  Installing : libXft-2.3.2-2.el7.x86_64                                                             46/88 
  Installing : libXi-1.7.9-1.el7.x86_64                                                              47/88 
  Installing : libXv-1.0.11-1.el7.x86_64                                                             48/88 
  Installing : libXxf86vm-1.1.4-1.el7.x86_64                                                         49/88 
  Installing : mesa-libGL-17.0.1-6.20170307.el7.x86_64                                               50/88 
  Installing : cairo-1.14.8-2.el7.x86_64                                                             51/88 
  Installing : pango-1.40.4-1.el7.x86_64                                                             52/88 
  Installing : glx-utils-8.2.0-3.el7.x86_64                                                          53/88 
  Installing : libXcomposite-0.4.4-4.1.el7.x86_64                                                    54/88 
  Installing : xcb-util-wm-0.4.1-5.el7.x86_64                                                        55/88 
  Installing : xcb-util-keysyms-0.4.0-1.el7.x86_64                                                   56/88 
  Installing : xcb-util-renderutil-0.3.9-3.el7.x86_64                                                57/88 
  Installing : xcb-util-0.4.0-2.el7.x86_64                                                           58/88 
  Installing : xcb-util-image-0.4.0-2.el7.x86_64                                                     59/88 
  Installing : qt5-qtbase-gui-5.6.2-1.el7.x86_64                                                     60/88 
  Installing : qt5-qtdeclarative-5.6.2-1.el7.x86_64                                                  61/88 
  Installing : qt5-qtlocation-5.6.2-1.el7.x86_64                                                     62/88 
  Installing : qt5-qtquickcontrols-5.6.2-1.el7.x86_64                                                63/88 
  Installing : qt5-qtwebchannel-5.6.2-1.el7.x86_64                                                   64/88 
  Installing : qt5-qtsensors-5.6.2-1.el7.x86_64                                                      65/88 
  Installing : qt5-qtx11extras-5.6.2-1.el7.x86_64                                                    66/88 
  Installing : orc-0.4.26-1.el7.x86_64                                                               67/88 
  Installing : gstreamer-plugins-base-0.10.36-10.el7.x86_64                                          68/88 
  Installing : qt5-qtwebkit-5.6.2-1.el7.x86_64                                                       69/88 
  Installing : teamviewer-host-13.1.1548-0.x86_64                                                    70/88 
  Updating   : 1:openssl-1.0.2k-8.el7.x86_64                                                         71/88 
  Updating   : systemd-sysv-219-42.el7_4.10.x86_64                                                   72/88 
  Updating   : initscripts-9.49.39-1.el7_4.1.x86_64                                                  73/88 
  Updating   : dracut-network-033-502.el7_4.1.x86_64                                                 74/88 
  Updating   : dracut-config-rescue-033-502.el7_4.1.x86_64                                           75/88 
  Updating   : libgudev1-219-42.el7_4.10.x86_64                                                      76/88 
  Cleanup    : dracut-config-rescue-033-161.el7.x86_64                                               77/88 
  Cleanup    : systemd-sysv-208-11.el7.x86_64                                                        78/88 
  Cleanup    : dracut-network-033-161.el7.x86_64                                                     79/88 
  Cleanup    : initscripts-9.49.17-1.el7.x86_64                                                      80/88 
  Cleanup    : libgudev1-208-11.el7.x86_64                                                           81/88 
  Cleanup    : dracut-033-161.el7.x86_64                                                             82/88 
  Cleanup    : systemd-208-11.el7.x86_64                                                             83/88 
  Cleanup    : 1:openssl-1.0.1e-34.el7.x86_64                                                        84/88 
  Cleanup    : 1:openssl-libs-1.0.1e-34.el7.x86_64                                                   85/88 
  Cleanup    : kmod-14-9.el7.x86_64                                                                  86/88 
  Cleanup    : systemd-libs-208-11.el7.x86_64                                                        87/88 
  Cleanup    : glib2-2.36.3-5.el7.x86_64                                                             88/88 
  Verifying  : libXext-1.3.3-3.el7.x86_64                                                             1/88 
  Verifying  : kmod-20-15.el7_4.7.x86_64                                                              2/88 
  Verifying  : libXi-1.7.9-1.el7.x86_64                                                               3/88 
  Verifying  : libXrender-0.9.10-1.el7.x86_64                                                         4/88 
  Verifying  : 1:cups-libs-1.6.3-29.el7.x86_64                                                        5/88 
  Verifying  : 2:libpng-1.5.13-7.el7_2.x86_64                                                         6/88 
  Verifying  : 2:libogg-1.3.0-7.el7.x86_64                                                            7/88 
  Verifying  : xcb-util-wm-0.4.1-5.el7.x86_64                                                         8/88 
  Verifying  : qt5-qtbase-gui-5.6.2-1.el7.x86_64                                                      9/88 
  Verifying  : gstreamer-0.10.36-7.el7.x86_64                                                        10/88 
  Verifying  : libXcomposite-0.4.4-4.1.el7.x86_64                                                    11/88 
  Verifying  : orc-0.4.26-1.el7.x86_64                                                               12/88 
  Verifying  : qt5-qtxmlpatterns-5.6.2-1.el7.x86_64                                                  13/88 
  Verifying  : pango-1.40.4-1.el7.x86_64                                                             14/88 
  Verifying  : mesa-libglapi-17.0.1-6.20170307.el7.x86_64                                            15/88 
  Verifying  : dracut-network-033-502.el7_4.1.x86_64                                                 16/88 
  Verifying  : qt5-qtlocation-5.6.2-1.el7.x86_64                                                     17/88 
  Verifying  : qt5-qtquickcontrols-5.6.2-1.el7.x86_64                                                18/88 
  Verifying  : libXau-1.0.8-2.1.el7.x86_64                                                           19/88 
  Verifying  : libicu-50.1.2-15.el7.x86_64                                                           20/88 
  Verifying  : iso-codes-3.46-2.el7.noarch                                                           21/88 
  Verifying  : libX11-1.6.5-1.el7.x86_64                                                             22/88 
  Verifying  : libICE-1.0.9-9.el7.x86_64                                                             23/88 
  Verifying  : dracut-033-502.el7_4.1.x86_64                                                         24/88 
  Verifying  : harfbuzz-1.3.2-1.el7.x86_64                                                           25/88 
  Verifying  : mesa-libgbm-17.0.1-6.20170307.el7.x86_64                                              26/88 
  Verifying  : qt5-qtwebchannel-5.6.2-1.el7.x86_64                                                   27/88 
  Verifying  : xcb-util-keysyms-0.4.0-1.el7.x86_64                                                   28/88 
  Verifying  : mesa-libGL-17.0.1-6.20170307.el7.x86_64                                               29/88 
  Verifying  : qt5-qtbase-common-5.6.2-1.el7.noarch                                                  30/88 
  Verifying  : 1:libtheora-1.1.1-8.el7.x86_64                                                        31/88 
  Verifying  : xcb-util-renderutil-0.3.9-3.el7.x86_64                                                32/88 
  Verifying  : libxcb-1.12-1.el7.x86_64                                                              33/88 
  Verifying  : systemd-219-42.el7_4.10.x86_64                                                        34/88 
  Verifying  : teamviewer-host-13.1.1548-0.x86_64                                                    35/88 
  Verifying  : pixman-0.34.0-1.el7.x86_64                                                            36/88 
  Verifying  : 1:libvorbis-1.3.3-8.el7.x86_64                                                        37/88 
  Verifying  : fontconfig-2.10.95-11.el7.x86_64                                                      38/88 
  Verifying  : graphite2-1.3.10-1.el7_3.x86_64                                                       39/88 
  Verifying  : libXfixes-5.0.3-1.el7.x86_64                                                          40/88 
  Verifying  : lyx-fonts-2.2.3-1.el7.noarch                                                          41/88 
  Verifying  : libjpeg-turbo-1.2.90-5.el7.x86_64                                                     42/88 
  Verifying  : libXv-1.0.11-1.el7.x86_64                                                             43/88 
  Verifying  : fontpackages-filesystem-1.44-8.el7.noarch                                             44/88 
  Verifying  : xcb-util-image-0.4.0-2.el7.x86_64                                                     45/88 
  Verifying  : 1:openssl-libs-1.0.2k-8.el7.x86_64                                                    46/88 
  Verifying  : cdparanoia-libs-10.2-17.el7.x86_64                                                    47/88 
  Verifying  : qt5-qtdeclarative-5.6.2-1.el7.x86_64                                                  48/88 
  Verifying  : mesa-libEGL-17.0.1-6.20170307.el7.x86_64                                              49/88 
  Verifying  : libvisual-0.4.0-16.el7.x86_64                                                         50/88 
  Verifying  : libxslt-1.1.28-5.el7.x86_64                                                           51/88 
  Verifying  : libgudev1-219-42.el7_4.10.x86_64                                                      52/88 
  Verifying  : libXxf86vm-1.1.4-1.el7.x86_64                                                         53/88 
  Verifying  : libX11-common-1.6.5-1.el7.noarch                                                      54/88 
  Verifying  : libxshmfence-1.2-1.el7.x86_64                                                         55/88 
  Verifying  : libSM-1.2.2-2.el7.x86_64                                                              56/88 
  Verifying  : xcb-util-0.4.0-2.el7.x86_64                                                           57/88 
  Verifying  : glib2-2.50.3-3.el7.x86_64                                                             58/88 
  Verifying  : libXdamage-1.1.4-4.1.el7.x86_64                                                       59/88 
  Verifying  : gstreamer-plugins-base-0.10.36-10.el7.x86_64                                          60/88 
  Verifying  : qt5-qtwebkit-5.6.2-1.el7.x86_64                                                       61/88 
  Verifying  : systemd-sysv-219-42.el7_4.10.x86_64                                                   62/88 
  Verifying  : cairo-1.14.8-2.el7.x86_64                                                             63/88 
  Verifying  : 1:openssl-1.0.2k-8.el7.x86_64                                                         64/88 
  Verifying  : qt5-qtbase-5.6.2-1.el7.x86_64                                                         65/88 
  Verifying  : dracut-config-rescue-033-502.el7_4.1.x86_64                                           66/88 
  Verifying  : libthai-0.1.14-9.el7.x86_64                                                           67/88 
  Verifying  : qt5-qtx11extras-5.6.2-1.el7.x86_64                                                    68/88 
  Verifying  : libXft-2.3.2-2.el7.x86_64                                                             69/88 
  Verifying  : systemd-libs-219-42.el7_4.10.x86_64                                                   70/88 
  Verifying  : libwebp-0.3.0-7.el7.x86_64                                                            71/88 
  Verifying  : glx-utils-8.2.0-3.el7.x86_64                                                          72/88 
  Verifying  : xml-common-0.6.3-39.el7.noarch                                                        73/88 
  Verifying  : initscripts-9.49.39-1.el7_4.1.x86_64                                                  74/88 
  Verifying  : qt5-qtsensors-5.6.2-1.el7.x86_64                                                      75/88 
  Verifying  : gstreamer-tools-0.10.36-7.el7.x86_64                                                  76/88 
  Verifying  : dracut-033-161.el7.x86_64                                                             77/88 
  Verifying  : dracut-network-033-161.el7.x86_64                                                     78/88 
  Verifying  : initscripts-9.49.17-1.el7.x86_64                                                      79/88 
  Verifying  : glib2-2.36.3-5.el7.x86_64                                                             80/88 
  Verifying  : systemd-sysv-208-11.el7.x86_64                                                        81/88 
  Verifying  : libgudev1-208-11.el7.x86_64                                                           82/88 
  Verifying  : dracut-config-rescue-033-161.el7.x86_64                                               83/88 
  Verifying  : kmod-14-9.el7.x86_64                                                                  84/88 
  Verifying  : systemd-208-11.el7.x86_64                                                             85/88 
  Verifying  : 1:openssl-libs-1.0.1e-34.el7.x86_64                                                   86/88 
  Verifying  : systemd-libs-208-11.el7.x86_64                                                        87/88 
  Verifying  : 1:openssl-1.0.1e-34.el7.x86_64                                                        88/88 


Installed:
  teamviewer-host.x86_64 0:13.1.1548-0                                                                     


Dependency Installed:
  cairo.x86_64 0:1.14.8-2.el7                            cdparanoia-libs.x86_64 0:10.2-17.el7              
  cups-libs.x86_64 1:1.6.3-29.el7                        fontconfig.x86_64 0:2.10.95-11.el7                
  fontpackages-filesystem.noarch 0:1.44-8.el7            glx-utils.x86_64 0:8.2.0-3.el7                    
  graphite2.x86_64 0:1.3.10-1.el7_3                      gstreamer.x86_64 0:0.10.36-7.el7                  
  gstreamer-plugins-base.x86_64 0:0.10.36-10.el7         gstreamer-tools.x86_64 0:0.10.36-7.el7            
  harfbuzz.x86_64 0:1.3.2-1.el7                          iso-codes.noarch 0:3.46-2.el7                     
  libICE.x86_64 0:1.0.9-9.el7                            libSM.x86_64 0:1.2.2-2.el7                        
  libX11.x86_64 0:1.6.5-1.el7                            libX11-common.noarch 0:1.6.5-1.el7                
  libXau.x86_64 0:1.0.8-2.1.el7                          libXcomposite.x86_64 0:0.4.4-4.1.el7              
  libXdamage.x86_64 0:1.1.4-4.1.el7                      libXext.x86_64 0:1.3.3-3.el7                      
  libXfixes.x86_64 0:5.0.3-1.el7                         libXft.x86_64 0:2.3.2-2.el7                       
  libXi.x86_64 0:1.7.9-1.el7                             libXrender.x86_64 0:0.9.10-1.el7                  
  libXv.x86_64 0:1.0.11-1.el7                            libXxf86vm.x86_64 0:1.1.4-1.el7                   
  libicu.x86_64 0:50.1.2-15.el7                          libjpeg-turbo.x86_64 0:1.2.90-5.el7               
  libogg.x86_64 2:1.3.0-7.el7                            libpng.x86_64 2:1.5.13-7.el7_2                    
  libthai.x86_64 0:0.1.14-9.el7                          libtheora.x86_64 1:1.1.1-8.el7                    
  libvisual.x86_64 0:0.4.0-16.el7                        libvorbis.x86_64 1:1.3.3-8.el7                    
  libwebp.x86_64 0:0.3.0-7.el7                           libxcb.x86_64 0:1.12-1.el7                        
  libxshmfence.x86_64 0:1.2-1.el7                        libxslt.x86_64 0:1.1.28-5.el7                     
  lyx-fonts.noarch 0:2.2.3-1.el7                         mesa-libEGL.x86_64 0:17.0.1-6.20170307.el7        
  mesa-libGL.x86_64 0:17.0.1-6.20170307.el7              mesa-libgbm.x86_64 0:17.0.1-6.20170307.el7        
  mesa-libglapi.x86_64 0:17.0.1-6.20170307.el7           orc.x86_64 0:0.4.26-1.el7                         
  pango.x86_64 0:1.40.4-1.el7                            pixman.x86_64 0:0.34.0-1.el7                      
  qt5-qtbase.x86_64 0:5.6.2-1.el7                        qt5-qtbase-common.noarch 0:5.6.2-1.el7            
  qt5-qtbase-gui.x86_64 0:5.6.2-1.el7                    qt5-qtdeclarative.x86_64 0:5.6.2-1.el7            
  qt5-qtlocation.x86_64 0:5.6.2-1.el7                    qt5-qtquickcontrols.x86_64 0:5.6.2-1.el7          
  qt5-qtsensors.x86_64 0:5.6.2-1.el7                     qt5-qtwebchannel.x86_64 0:5.6.2-1.el7             
  qt5-qtwebkit.x86_64 0:5.6.2-1.el7                      qt5-qtx11extras.x86_64 0:5.6.2-1.el7              
  qt5-qtxmlpatterns.x86_64 0:5.6.2-1.el7                 xcb-util.x86_64 0:0.4.0-2.el7                     
  xcb-util-image.x86_64 0:0.4.0-2.el7                    xcb-util-keysyms.x86_64 0:0.4.0-1.el7             
  xcb-util-renderutil.x86_64 0:0.3.9-3.el7               xcb-util-wm.x86_64 0:0.4.1-5.el7                  
  xml-common.noarch 0:0.6.3-39.el7                      


Updated:
  dracut.x86_64 0:033-502.el7_4.1                  initscripts.x86_64 0:9.49.39-1.el7_4.1                 


Dependency Updated:
  dracut-config-rescue.x86_64 0:033-502.el7_4.1           dracut-network.x86_64 0:033-502.el7_4.1          
  glib2.x86_64 0:2.50.3-3.el7                             kmod.x86_64 0:20-15.el7_4.7                      
  libgudev1.x86_64 0:219-42.el7_4.10                      openssl.x86_64 1:1.0.2k-8.el7                    
  openssl-libs.x86_64 1:1.0.2k-8.el7                      systemd.x86_64 0:219-42.el7_4.10                 
  systemd-libs.x86_64 0:219-42.el7_4.10                   systemd-sysv.x86_64 0:219-42.el7_4.10            


Complete!
[root@localhost ~]# ll /etc/yum.repos.d/
total 28
-rw-r--r--. 1 root root 1612 Jul  4  2014 CentOS-Base.repo
-rw-r--r--. 1 root root  640 Jul  4  2014 CentOS-Debuginfo.repo
-rw-r--r--. 1 root root 1331 Jul  4  2014 CentOS-Sources.repo
-rw-r--r--. 1 root root  156 Jul  4  2014 CentOS-Vault.repo
-rw-r--r--. 1 root root  957 Dec 27  2016 epel.repo
-rw-r--r--. 1 root root 1056 Dec 27  2016 epel-testing.repo
-rw-r--r--. 1 root root  217 Mar  9 09:44 teamviewer.repo

最后出现Complete!表示安装完成。

启动

默认会安装到/opt/teamview里面,并且安装成功会默认启动

cd /opt/teamviewer/tv_bin/

用teamviewer --info命令可查看teamview运行状态


如果没有设置密码,TeamViewer ID: 后面会是空的,

执行命令 teamviewer --passwd 你的密码

再次运行teamviewer --info命令就可以看到ID了

good luck!


附录:
cd /opt/teamviewer/tv_bin  
teamviewer --setup console #设置启动方式为控制台启动  
teamviewer --daemon restart  #重启teamview服务  
teamviewer --info #查看teamview信息  
teamviewer --passwd [PASSWD]   #设置密码  

teamviewer --help  #查看帮助 

teamviewer登陆效果图,登陆过程会让你输入用户名与密码~~



阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页