HDU 1059 多重背包 二进制

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20070    Accepted Submission(s): 5627


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source
#include<stdio.h>
#include<string.h> 
#include<math.h>
int lg(int x) 
{
	int t=0;
	while(x>=2)
	{
		x=x/2;
		t++;
	}
	return t;
}//求logn(2为底)
int sc(int a[])
{
	int t=0,i;
	for(i=1;i<=6;i++)
	{
		scanf("%d",&a[i]);
		if(a[i]==0)
		{
			t++;
		}
			
	}	if(t==6)
		return 0;
		else return 1;
	
	
}//输入函数,如果全输入0 返回0,否则则返回1;
int main()
{
	int a[7],d[120008],i,j,count=0,b[20008];
	//freopen("input.txt","r",stdin);
	while(sc(a)!=0)
	{
		int l=0;
		memset(d,0,sizeof(d));
		count ++;
		int sum=0,t=1,f;
		for(i=1;i<7;i++)
		{
			if(a[i]!=0) 
			{
				for(j=0;j<lg(a[i]-1);j++)
				{
					b[l++]=pow(2,j)*i;
				}
				 b[l++]=a[i]*i-pow(2,j)*i+i;
			}
		}//转换为01背包
		for(i=1;i<7;i++)
		{
			if(a[i]!=0) 
			{
				sum+=a[i]*i;
			}
		}求总共的价值(背包容量)
		if(sum%2!=0) t=0;//总量为奇数数肯定不能分成相等的两份;
		else {
			for(i=0;i<l;i++)
			{
				for(j=sum/2;j>=b[i];j--)
				{
					if(d[j]<=d[j-b[i]]+b[i])
					{
						d[j]=d[j-b[i]]+b[i];
					}
				}
			}
				
		}
		if(d[sum/2]!=sum/2) t=0;
		printf("Collection #%d:\n",count);
		if(t) printf("Can be divided.\n");
		else printf("Can't be divided.\n");
		printf("\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Eclipse二进制文件是指由Eclipse集成开发环境生成的可执行文件。在Linux下,Eclipse生成的二进制文件通常是没有扩展名的,如上述引用所示。在使用Eclipse编译和运行项目时,如果项目名包含扩展名(例如.hdu.c),则Eclipse可能无法正确识别该文件为二进制可执行文件。 这可能导致在运行时出现找不到二进制文件的错误。解决办法有两种:一是避免使用带有扩展名的项目名,另一种是手动创建一个运行配置,将命令写死以确保正确识别为二进制文件。 需要注意的是,上述讨论中的EclipseParser库是一个用于验证和读取Eclipse二进制文件内容的DLL库,它是通过按照二进制格式编写的。这个库可以验证和读取Eclipse二进制文件中的EGRID、INIT、UNRST等内容。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [linux下eclipse c++运行不了提示找不到二进制文件的解决方法](https://blog.csdn.net/bjrxyz/article/details/8974483)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* *3* [Eclipse油藏数值模拟软件的二进制文件格式解析](https://blog.csdn.net/slofslb/article/details/119176891)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值