HDU 1242 Rescue 【BFS+模板】

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison. 

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards. 

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.) 

Input

First line contains two integers stand for N and M. 

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file. 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

思路:从 r 走到 a ,遇到 . 算走一步,遇到 x 算两步,问能否到 a。BFS模板题。代码如下:

//用队列实现BFS 
#include<bits/stdc++.h>
#include<queue>
using namespace std;
#define MAXN 200+5
int n,m;
char str[MAXN][MAXN];
int vis[MAXN][MAXN]; //标记数组 
struct node{
	int x;
	int y;
	int step;
	bool friend operator < (node a,node b){
		return a.step>b.step;
	}
};
int d[4][2]={-1,0,1,0,0,1,0,-1};
void BFS(int x1,int y1,int x2,int y2 ){
	memset(vis,0,sizeof(vis));
	priority_queue<node>que;
	node e1,e2;
	e1.x=x1,e1.y=y1,e1.step=0;
	que.push(e1);
	vis[x1][y1]=1;
	int ans=-1;
	while(!que.empty()){
		e1=que.top();
		que.pop();
		if(e1.x==x2&&e1.y==y2){
			ans=e1.step;
			break;
		}
		for(int i=0;i<4;i++){
			e2.x=e1.x+d[i][1];
			e2.y=e1.y+d[i][0];
			if(e2.x<0||e2.y<0||e2.x>=n||e2.y>=m||vis[e2.x][e2.y]||str[e2.x][e2.y]=='#') continue;//剪枝操作 
			//if(vis[e2.x][e2.y]==1)  continue;
			//if(str[e2.x][e2.y]=='#') continue;
			if(str[e2.x][e2.y]=='x')
			   e2.step=e1.step+2;
			else
			   e2.step=e1.step+1;
			que.push(e2);
			vis[e2.x][e2.y]=1;
		}
	}
	if(ans==-1)
	   cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
	else
	  cout<<ans<<endl;
}
int main(){
	int a1,b,c,d;
	int i,j;
	while(cin>>n>>m){
		for(i=0;i<n;i++)
		   cin>>str[i];
		for(i=0;i<n;i++)  //记录起点和终点 
		  for(j=0;j<m;j++){
			if(str[i][j]=='a')  a1=i,b=j;
			if(str[i][j]=='r')  c=i,d=j;
		}
	BFS(a1,b,c,d);  //调用BFS 
}
	return 0;
}

ps:如果有一天老了,我依然会待你如初!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值