1018 Public Bike Management (30分)【Dijstra+dfs】

1018 Public Bike Management (30分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

 解题思路:

这道题的大致意思是:

  1. 找从0点到sp点的最短路;
  2. 若不唯一,找其中需要送出自行车最少的路径;
  3. 若还不唯一,找其中需要回收自行车最少的路径;

最开始,我觉的像是写过的这么一道题城市间紧急救援 ,但是后来发现这道题不仅仅要我们找能收集最多自行车的那条路,同时若收集到了足够自行车后要保证多余的车数量又要最少。 即并不是一个最优子问题。

参考柳神的博客后,才明白这可以用DIjkstra+DFS来做,首先先找到最短路,并记录下每条最短路中终点的前驱结点。最后再用一遍DFS遍历所有最短路径,并统计最小需要的自行车数和最小带回自行车数。

#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
#define INF 0xffffff

int capacity, n, sp, m;

int edge[510][510];   //邻接表
int bikes[510];          //各站的自行车数
int dist[510];          //储存出发点到i的最短路径长度
int s[510];             //储存已访问的点集
vector<int> pre[510];   //用于储存到i的最短路径时,i的前驱结点
vector<int> path, tmp;  //用于存储路径
int minAdd = INF, minBack = INF;

void Dijstra(int v)
{
	fill(dist, dist + 510, INF);
	dist[v] = 0;
	for (int i = 0; i <= n; i++)
	{
		int u = -1;
		int minx = INF;
		for (int j = 0; j <= n; j++)
		{
			if (dist[j] < minx&&s[j]==0)
			{
				minx = dist[j];
				u = j;
			}
		}
		if (u == -1)break;
		s[u] = 1;    //将点u加入集合
		for (int j = 0;j <= n; j++)
		{
			if (s[j] == 0 && edge[u][j] != INF)
			{
				if (dist[j] > dist[u] + edge[u][j])   //如果最短路径要修改,则j的最短路径的前驱点得改变
				{
					dist[j] = dist[u] + edge[u][j];
					pre[j].clear();
					pre[j].push_back(u);
				}
				else if (dist[j] == dist[u] + edge[u][j])  //如果有相同长度的路径,这将该路径下j的前驱点加入
				{
					pre[j].push_back(u);
				}
			}
		}
	}
}

void dfs(int v)
{
	tmp.push_back(v);
	if (v == 0)    //到起点了
	{
		int tmpAdd=0, tmpBack=0;
		for (int i = tmp.size() - 1; i >= 0; i--)     //遍历路径上的站
		{
			if (bikes[tmp[i]] >= 0)            //如果当前站车有多,则得待会
			{
				tmpBack += bikes[tmp[i]];
			}
			else                                   //如果当前站车数量不够
			{
				if (tmpBack >= abs(bikes[tmp[i]]))  //如果要带回的车能补充该站
					tmpBack += bikes[tmp[i]];
				else                                       //否则还不够,需要PBMC补充
				{
					tmpAdd -= (tmpBack + bikes[tmp[i]]);
					tmpBack = 0;
				}
			}
		}
		if(tmpAdd < minAdd) 
		{
			minAdd = tmpAdd;
			minBack = tmpBack;
			path = tmp;
		} 
		else if(tmpAdd == minAdd && tmpBack < minBack) 
		{
			minBack = tmpBack;
			path = tmp;
		}
		tmp.pop_back();
		return ;
	}
	else
	{
		for (int i = 0; i < pre[v].size(); i++)
			dfs(pre[v][i]);
		tmp.pop_back();              //回溯
	}
}

int main()
{
	cin >> capacity >> n >> sp >> m;
	fill(edge[0], edge[0] + 510 * 510, INF);
	for (int i = 1; i <= n; i++)
	{
		cin >> bikes[i];
		bikes[i] = bikes[i] - capacity / 2;
	}
	for (int i = 0; i < m; i++)
	{
		int a, b, w;
		cin >> a >> b >> w;
		edge[a][b] = edge[b][a] = w;
	}
	Dijstra(0);
	dfs(sp);
	cout << minAdd << " 0";
	for (int i = path.size() - 2; i >= 0; i--)
		cout << "->" << path[i];
	cout << " "<<minBack << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值