【PAT(甲级)】1018 Public Bike Management

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3​, we have 2 different shortest paths:

  1. PBMC -> S1​ -> S3​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1​ and then take 5 bikes to S3​, so that both stations will be in perfect conditions.

  2. PBMC -> S2​ -> S3​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; Sp​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci​ (i=1,⋯,N) where each Ci​ is the current number of bikes at Si​ respectively. Then M lines follow, each contains 3 numbers: Si​, Sj​, and Tij​ which describe the time Tij​ taken to move betwen stations Si​ and Sj​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S1​−>⋯−>Sp​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

解题思路:

题目大意是提出一个有问题的景点Sp,让你找到PBMC距离这个景点的最短路径,如果最短路径不止一条,则要求你找到提供自行车数量最少的,提供自行车数量相同时,输出带回自行车数量最少的。返回时不会沿途补充景点上的自行车数量,忽视这一点测试点5,7会错。

很自然地最短路径想到用dijkstra算法求,因为最短路径不止一条,所以存储pre时用vector比较方便,当然用数组也是可以的。对于自行车数量,因为你已经通过最短路径算法求出路径了,只要用dfs算法进行遍历就可以求出题目要求下的最佳路径(将退出循环的条件设置为与自行车相关)。

易错点:

注意别以为带回的自行车数量可以用来补充带来的自行车数量。比如路径上: +3->-2->-7(+代表需要带的自行车数量,减代表需要带走的自行车数量),这条路径就是要带3辆自行车,带走9辆,而不是带0量,带走6辆。

代码:

#include<bits/stdc++.h>
using namespace std;

#define inf 10000000
#define max 600 

int C,N,S,M;
int bike[max];//每个景点的自行车数量 
int G[max][max];//存储图 
int dist[max];
int minin = inf,minout = inf;
bool visit[max] = {false};
vector<int> pre[max];//存储前一个景点 
vector<int> path, tpath;

void dijkstra(int s){//用dijkstra算法求出路径最短的几条路 
	fill(dist,dist+max,inf);
	dist[s] = 0;
	while(true){
		int u = -1, min = inf;
		for(int i=0;i<=N;i++){
			if(!visit[i]&&dist[i]<min){
				min = dist[i];
				u = i;
			}
		}
		if(u==-1) return;
		visit[u] = 1;
		for(int i=0;i<=N;i++){
			if(!visit[i]&&G[u][i]!=inf){
				if(dist[u]+G[u][i]<dist[i]){
					//当有最新的路径时,清空前面的存储,将新节点放入 
					dist[i] = dist[u]+G[u][i];
					pre[i].clear();
					pre[i].push_back(u);
				}
				else if(dist[u]+G[u][i]==dist[i]){
					//路径一样长时,按照题意还是要存储下来,后面再次判断 
					pre[i].push_back(u);
				}
			}
		}
	}
}

void dfs(int a){//用dfs算法求出所需供应和回放最少的自行车的路径 
	tpath.push_back(a);
	if(a==0){
		int minint = 0,minoutt = 0;
		for(int i = tpath.size()-2;i>=0;i--){
		//因为此时已经将0放入末尾,找前一个路径就要减2 
			int t = tpath[i];
			if(minoutt + bike[t] < C/2){
				minint +=C/2-(minoutt + bike[t]);
				minoutt=0;
			}
			else{
				if(bike[t]>C/2){
					minoutt+=bike[t]-C/2;
				}
				else{
					minoutt-=C/2-bike[t];
				}
			}
		}

		if(minint<minin){
			minin = minint;
			path = tpath;
			minout = minoutt;
		}
		else if(minin==minint&&minout>minoutt){
			path = tpath;
			minout = minoutt;
		}
		tpath.pop_back();
		return;
	}
	for(int i=0;i<pre[a].size();i++){
		dfs(pre[a][i]);
	}
	tpath.pop_back();
}

int main(){
	fill(G[0],G[0]+max*max,inf);
	cin>>C>>N>>S>>M;
	for(int i=1;i<=N;i++){
		cin>>bike[i];
	}
	for(int i=0;i<M;i++){
		int x,y,z;
		cin>>x>>y>>z;
		G[x][y]=z;
		G[y][x]=z; 
	}
	dijkstra(0);
	dfs(S);
	
	cout<<minin<<" ";
	for(int i=path.size()-1;i>=0;i--){
		cout<<path[i];
		if(i) cout<<"->";
	}
	cout<<" "<<minout<<endl;
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值