1060 Are They Equal (25分)【string】

1060 Are They Equal (25分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10​5​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10​100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

题目大意:

给出两个数,问将它们写成保留N位小数的科学计数法后是否相等。如果相等,则输出“YES”,并给出该转换结果;如果不等,则输出“NO”,并给出两个数的转换结果。

解题思路:

题目要求我们将两个数改写为科学计数法的形式,然后判断它们是否相等。而科学计数法的写法一定是如下格式:0.a_1a_2a_3...\times10^e,因此我们只需获取到科学计数法的有效位部分a_1a_2a_3与指数e,即可判定两个数在科学计数法形式下是否相等。

首先,我们分两种情况考虑1、是小数点前面为0;2、是小数点前面不为0。

对于情况1由于小数点后面还有可能有多个0,因此我们的有效位是小数点后第一个非0的数开始取3位数,指数则是小数点与该非0位之间的位数的相反数。而对于情况2,有效位很显然就是从第一位数开始3位数,指数则是小数点前的数位的总位数(但是这里需要注意一个陷阱,就是在数据之前可能还会有若干个0,例如000.001或000111.1,因此需要消除前导0)。

#include<iostream>
#include<cstdio>
#include<string>
using namespace std;

int n;

string fun(string str, int &e)    //返回有效位以及指数
{
	int k = 0;
	while (str.length() > 0 && str[0] == '0')
		str.erase(str.begin());                          //去除前导0
	if (str[0] == '.')                      //若是小数点则去掉小数点
	{
		str.erase(str.begin());
		while (str.length() > 0 && str[0] == '0')
		{
			str.erase(str.begin());                           //去掉小数点后非零位前的所有0
			e--;                                                      //指数减1
		}
	}
	else                                     //否则去掉前导0后不是小数点,则找到后面的小数点删除
	{
		while (k < str.length() && str[k] != '.')               //寻找小数点
		{
			k++;
			e++;
		}
		if (k < str.length())
		{
			str.erase(str.begin() + k);
		}
	}
	if (str.length() == 0)   //如果去除前导0后s的长度变为0,则说明这个数是0
	{
		e = 0;
	}
	int num = 0;
	k = 0;
	string res;
	while (num < n)
	{
		if (k < str.length())
			res += str[k++];
		else res += '0';
		num++;
	}
	return res;
}

int main()
{
	string s1, s2, s3, s4;
	cin >> n >> s1 >> s2;
	int e1 = 0, e2 = 0;
	s3 = fun(s1, e1);
	s4 = fun(s2, e2);
	if (s3 == s4&&e1 == e2)
	{
		cout << "YES 0." << s3 << "*10^" << e1 << endl;
	}
	else
	{
		cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^" << e2 << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值