1060. Are They Equal (25)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3

判断两个数以题目给定的模式表示是否一样,并且输出结果。要考虑的情况比较多,比如123,0.002,0002.2,02.200003,0.,.023等形式的数字都可能有。我这里主要分成两大类,就是大于等于1的和小于1的。对于一个以字符串形式输入的数,首先先把前面的0排除掉。如果当前字符为‘.'且后面还有数,说明小于1,就遍历字符串,找出n位有效数字,如果不够n位就补零补足n位,同时也求出指数ex。如果当前字符不是‘.',说明大于等于1,遍历字符串直到找到‘.',同时添加有效数字,和求出指数ex,然后跳过‘.',继续补全有效数字,如果最后也不足n个,就补零。最后比较有效数字就能判断两个数是否“相等“。最后按题目指定形式输出结果。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
using namespace std;

int get_num(char *s,int n,string &num)
{
	int m=strlen(s);
	int i=0,ex;
	while(i<m&&s[i]=='0') i++;
	if(i<m&&s[i]=='.')
	{
		i++;
		ex=0;
		while(i<m&&s[i]=='0')
		{
			i++;
			ex--;
		}
		while(i<m&&num.size()<n)
		{
			num+=s[i++];
		}
		while(num.size()<n)
		{
			num+='0';
		}
		return ex;
	}
	else
	{
		ex=0;
		while(i<m&&s[i]!='.')
		{
			ex++;
			if(num.size()<n)
			{
				num+=s[i];
			}
			i++;
		}
		i++;
		while(i<m&&num.size()<n)
		{
			num+=s[i++];
		}
		while(num.size()<n)
		{
			num+='0';
		}
		return ex;
	}
}

int main()
{
	int n;
	char s1[105],s2[105];
	scanf("%d %s %s",&n,s1,s2);
	string res1,res2;
	int ex1=get_num(s1,n,res1);
	int ex2=get_num(s2,n,res2);
	if(res1[0]=='0') ex1=0;
	if(res2[0]=='0') ex2=0;
	if(res1==res2&&ex1==ex2)
	{
		printf("YES 0.%s*10^%d",res1.c_str(),ex1);
	}
	else
	{
		printf("NO 0.%s*10^%d 0.%s*10^%d",res1.c_str(),ex1,res2.c_str(),ex2);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值