POJ2240 Arbitrage【Bellman_Ford】

 Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

解题思路

题目大意:货币间的汇率大家都知道,这道题目会告诉我们一些货币之间的汇率,然后要我们判断这些货币之间是否存在通过从美元开始然后经过多次兑换后使得资金增加的决策。

思路:这道题目其实和POJ1860 Currency Exchange是一样的思路。其实就是判断图中是否存在正环。这里可以使用BellmanFord算法或者使用SPFA(我这里代码实现的是Bellman Ford)。这里为了方便对货币进行编号,我使用了map对货币进行存储。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<map>
#include<algorithm>
using namespace std;
int n, m;
int edge[2500][2];
double rate[2500];
map<string, int> cur;         //货币名对应编号
double dist[50];

int main()
{
	int cnt = 0;
	while (scanf("%d", &n) && n)
	{
		for (int i = 1; i <= n; i++)
		{
			string s;
			cin >> s;
			cur[s] = i;
		}
		scanf("%d", &m);
		for (int i = 1; i <= m; i++)
		{
			string c1, c2;
			double r;
			cin >> c1 >> r >> c2;
			edge[i][0] = cur[c1];
			edge[i][1] = cur[c2];
			rate[i] = r;
		}
		//Bellman_Fod
		memset(dist, 0, sizeof(dist));
		dist[cur["USDollar"]] = 100.0;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				if (dist[edge[j][1]] < dist[edge[j][0]] * rate[j])
					dist[edge[j][1]] = dist[edge[j][0]] * rate[j];
			}
		}
		int flag = 0;
		for (int j = 1; j <= m; j++)    //判断是否存在正环
		{
			if (dist[edge[j][1]] < dist[edge[j][0]] * rate[j])
			{
				flag = 1;
				break;
			}
		}
		printf("Case %d: ", ++cnt);
		if (flag)
			printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值