POJ1860 Currency Exchange【Bellman_Ford】

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

 解题思路

题目大意:有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到(100 - 0.39) * 29.75 = 2963.3975 B币。问s币的金额经过交换最终得到的s币金额数能否增加。其中货币的交换是可以重复多次的,所以我们需要找出是否存在正权回路,且最后得到的s金额是增加的。那么怎么找正权回路呢?(正权回路:在这一回路上,顶点的权值能不断增加即能一直进行松弛)

思路:一种货币就是一个点。一个“兑换点”就是图上两种货币之间的一个兑换方式,是双边,但A到B的汇率和手续费可能与B到A的汇率和手续费不同。唯一值得注意的是权值,当拥有货币A的数量为V时,A到A的权值为K,即没有兑换。而A到B的权值为(V-Cab)*Rab。本题其实是“求最大路径”,之所以被归类为“求最小路径”是因为本题题恰恰与bellman-Ford算法的松弛条件相反,求的是能无限松弛的最大正权路径,但是依然能够利用bellman-Ford的思想去解题。相比于原算法判断负环,这里我们要寻找正环,当存在正环则说明我们可以使其增加。
 

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
int n, m, s, c;
double v, dist[110];

struct node {
	int a, b;
	double r, c;
}p[500];

int main()
{
	int a, b;
	double r1, r2, c1, c2;
	scanf("%d%d%d%lf", &n, &m, &s, &v);
	for (int i = 1; i <= m; i++)          //转化为2*m条边
	{
		scanf("%d%d%lf%lf%lf%lf", &a, &b, &r1, &c1, &r2, &c2);
		p[i].a = a;
		p[i].b = b;
		p[i].r = r1;
		p[i].c = c1;
		p[i + m].a = b;
		p[i + m].b = a;
		p[i + m].r = r2;
		p[i + m].c = c2;
	}
	memset(dist, 0, sizeof(dist));
	dist[s] = v;
	for (int i = 1; i <= n; i++)
	{
		for (int j = 1; j <= 2 * m; j++)
		{
			double w = (dist[p[j].a] - p[j].c)*p[j].r;
			if (w > dist[p[j].b])
				dist[p[j].b] = w;
		}
	}
	int flag = 0;                     //寻找正环
	for (int i = 1; i <= 2 * m; i++)
	{
		double w = (dist[p[i].a] - p[i].c)*p[i].r;
		if (w > dist[p[i].b])
		{
			flag = 1;
			break;
		}
	}
	if (flag)
		printf("YES\n");
	else printf("NO\n");
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值