1002 A+B for Polynomials (25 分)【模拟】

1002 A+B for Polynomials (25 分)

This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.
Output Specification:
For each test case you should output the sum of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

一上来,想用map存放多项式的系数和指数,代码如下:

#include<iostream>
#include<cstdio>
#include<map>
#include<functional>
using namespace std;

int main()
{
    map<int,double,greater<int> > poly;
for(int i = 0;i<2;i++)
{
int t;
        cin>>t;
for(int j = 0;j<t;j++)
{
int n;
double m;
            cin>>n>>m;
if(poly.find(n)==poly.end())
                poly[n] = m;
else
                poly[n]+=m;
}
}
    cout<<poly.size();
    map<int,double>::iterator it;
for(it = poly.begin();it!=poly.end();it++)
{
        cout<<" "<<it->first<<" ";
printf("%.1lf",it->second);
}
return 0;
}

然而最后四个测试样例报错,再仔细读题后发现,对于系数为0的数据不显示,因此修改后的代码如下:

#include<iostream>
#include<cstdio>
#include<map>
#include<functional>
using namespace std;


int main()
{
    map<int,double,greater<int> > poly;
    for(int i = 0;i<2;i++)
    {
        int t;
        cin>>t;
        for(int j = 0;j<t;j++)
        {
            int n;
            double m;
            cin>>n>>m;
            if(poly.find(n)==poly.end())
                poly[n] = m;
            else
                poly[n]+=m;
        }
    }
    int sum = poly.size();
    map<int,double>::iterator it;
    for(it = poly.begin();it!=poly.end();it++)
    {
        if(it->second==0)
            sum--;
    }
    cout<<sum;
    for(it = poly.begin();it!=poly.end();it++)
    {
        if(it->second!=0)
        {
            cout<<" "<<it->first<<" ";
            printf("%.1lf",it->second);
        }
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值