hdu 5391 Zball in Tina Town

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 307    Accepted Submission(s): 187


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes  1  time as large as its original size. On the second day,it will become 2  times as large as the size on the first day. On the n-th day,it will become  n  times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

Input
The first line of input contains an integer  T , representing the number of cases.

The following  T  lines, each line contains an integer  n , according to the description.
T105,2n109
 

Output
For each test case, output an integer representing the answer.
 

Sample Input
  
  
2 3 10
 

Sample Output
  
  
2 0
 

Source
 
n是质数为N-1,不是为0,特判4


#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;

int check[100000];
vector<int> pri;
void init(){
    memset(check,0,sizeof(check));
    pri.clear();
    for(int i = 2;i < 100000; i++){
        if(check[i] == 0) {
            pri.push_back(i);
            for(int j = i+i;j < 100000; j += i){
                check[j] = 1;
            }
        }
    }
}

int main(){
    int n;
    int t;
    init();
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        if(n == 4){
            printf("2\n");
            continue;
        }
        if(n < 100000){
            if(check[n] == 0){
                printf("%d\n",n-1);
            }
            else printf("0\n");
        }
        else {
            int flag = 1;
            for(int i = 0;i < pri.size() && flag && pri[i]*pri[i] <= n ; i++){
                if(n % pri[i] == 0){
                    flag = 0;
                }
            }
            if(flag)printf("%d\n",n-1);
            else printf("0\n");
        }
    }
    return 0;
}





















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值