HDU 5391 威尔逊定理

http://acm.hdu.edu.cn/showproblem.php?pid=5391

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 11 time as large as its original size. On the second day,it will become 22 times as large as the size on the first day. On the n-th day,it will become nn times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.

Input

The first line of input contains an integer TT, representing the number of cases.

The following TT lines, each line contains an integer nn, according to the description.
T≤105,2≤n≤109T≤105,2≤n≤109

Output

For each test case, output an integer representing the answer.

Sample Input

2
3
10

Sample Output

2
0

题目大意:输出(n-1)!%n

思路:威尔逊定理:当且仅当p为素数时,p整除(p-1)!+1,也即(p-1)!+1=kp,那么我们可以得到,当p为素数时,(p-1)!%p=p-1。考虑当p为合数时,必定可以表示成几个质数的乘积,那么必定可以整除(n-1)!,即当p为合数时,(n-1)!%p=0,再注意n=4时是特殊情况。

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
#define EPS 1e-10
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

bool prime(int n)
{
	if(n==2||n==3)
		return true;
	for(int i=2;i*i<=n;i++)
		if(n%i==0)
			return false;
	return true;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		if(n==4)
			printf("%d\n",2);
		else if(prime(n))
			printf("%d\n",n-1);
		else
			printf("0\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值