4.13 PAT 甲级 1075 PAT Judge

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10​4​​), the total number of users, K (≤5), the total number of problems, and M (≤10​5​​), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
#include<iostream>
#include<unordered_map>
#include<vector>
#include<algorithm>
using namespace std;

int n,k,m;
int full_grades[6];
struct Student
{
    string id;
    bool is_exist;
    int sum;           //总成绩
    int full_num;      //满分的科目数量
    int grades[6];      //记录各科成绩
};

bool cmp(Student &a,Student &b)
{
    if(a.sum != b.sum)
        return a.sum > b.sum;
    else
    {
        if(a.full_num != b.full_num)
            return a.full_num > b.full_num;
        else
            return a.id < b.id;
    }
}
unordered_map<string,Student>students;
vector<Student>student;
int main()
{
    cin >> n >> k >> m;

    for(int i = 1; i <= k; i ++ )
        cin >> full_grades[i];

    while(m --)
    {
        string id;
        int no,grade;
        cin >> id >> no >> grade;
        if(!students.count(id))
            students[id] = {id,false,0,0,{-2,-2,-2,-2,-2,-2}};

        if(grade >= 0)
        {
            auto &s = students[id];
            s.is_exist = true;
            s.grades[no] = max(s.grades[no],grade);
        }
        else
            students[id].grades[no] = max(students[id].grades[no],0);
    }

    for(auto& stu : students)
    {
        auto &s = stu.second;
        if(s.is_exist)
        {
            for(int i = 1; i <= 5; i++)
            {
                s.sum += max(0,s.grades[i]);
                if(s.grades[i] == full_grades[i])
                    s.full_num++;
            }
            student.push_back(s);
        }
    }

    sort(student.begin(),student.end(),cmp);

    for(int i = 0,rank = 1; i < student.size(); i ++ )
    {
        if(!i || student[i].sum != student[i - 1].sum)
            rank = i + 1;
        cout << rank << ' ' <<student[i].id << ' ' << student[i].sum;
        for(int j = 1; j <= k; j ++)
        {
            if(student[i].grades[j] == -2)
                cout << ' ' << '-';
            else
                cout << ' ' << student[i].grades[j];
        }
        cout << endl;
    }
}

精神胜利法太管用了hhh对付这种题真的要逼着自己耐心。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值