PAT 甲级 1038 Recover the Smallest Number

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10
​4) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

解题思路:
1.这一题直接用简单的排序并不行,比如32和321,按字典序排序后32在321前面,然而321输出在前面得到的数字小。所以排序函数如下:

bool cmp(string a,string b)
{
	return a + b < b + a;
}

2.对于前导0的处理使用erase()函数消除,若字符串的长度为零则输出0.

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
bool cmp(string a,string b)
{
	return a + b < b + a;
}
using namespace std;
int main(void)
{
	int N,P;
	string a[10000];
	string out;
	cin >> N ;
	for(int i = 0;i < N;i++)
	{
		cin >> a[i];
	}
	sort(a,a+N,cmp);
	for(int i = 0;i < N;i++)
	{
		out+=a[i];
	}
	while(out.size()!=0&&out[0]=='0')
	{
		out.erase(out.begin());
	}
	if(out.size() == 0)
		cout << "0";
	else
		cout << out;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值