PAT 甲级 1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4
解题思路:本题给出一串序列要求根据这个序列构造完全二叉排序树,输出层序遍历。本题要注意完全二叉树的特点,若用数组按照层序存储每个结点信息,若当前结点为i左孩子为2i,右孩子为2i+1。其次二叉排序树的中序遍历为有序序列,所以将输入的序列排序后,中序遍历将数值填入数组中,按顺序输出数组中的数就是层序遍历的序列。
代码:
#include<cstdio>
#include<algorithm>
using namespace std;
int a[1010];
int b[1010];
int N;
int start = 0;
void inorder(int i)
{
	if(i > N)  //这里很巧妙
		return ;
	inorder(2*i);
	b[i] = a[start++];
	inorder(2*i+1);
}
int main(void){
	scanf("%d",&N);
	for(int i = 0;i < N;i++){
		scanf("%d",&a[i]);
	}
	sort(a,a+N);
	inorder(1);
	for(int i = 1 ;i <= N;i++)
	{
		printf("%d",b[i]);
		if(i!=N)
			printf(" ");
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值