PAT 甲级 1107 Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​ : h​i​​ [1] h​i​​ [2] … h​i​​ [K​i​]
where K​i​​ (>0) is the number of hobbies, and h​i​​ [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1
解题思路:本题给出每个同学喜欢的活动,有相同喜欢活动的可以化为一个群体,求出可以分成几个群体。本题主要通过并查集做,用hobby[i]存储任意一个喜欢活动i的学生,之后将hobby[i]与当前喜欢该活动的学生合并即可。
代码:
#include<cstdio>
#include<algorithm>
using namespace std;
int out[1010];
int hobby[1010] = {0};
int father[1010] = {0};
void init(int n){
	for(int i = 1;i <= n;i++){
		father[i] = i;
	}
}
int findFather(int x){
	while(x != father[x]){
		x = father[x];
	}
	return x;
}
int isroot[1010] = {0};
void Union(int a,int b){
	int AF = findFather(a);
	int BF = findFather(b);
	if(AF!=BF){
		father[AF] = BF;
	}
}
int main(void){
	int N,sum = 0;
	scanf("%d",&N);
	init(N);
	for(int i = 1; i <= N;i++){
		int num;
		scanf("%d:",&num);
		for(int j = 0;j < num;j++){
			int hobbynum;
			scanf("%d",&hobbynum);
			if(hobby[hobbynum] == 0)
				hobby[hobbynum] = i;
			else
				Union(hobby[hobbynum],i);
		}
	}
	for(int i = 1;i <= N;i++){
		isroot[findFather(i)]++;
	}
	for(int i = 1;i <= N;i++){
		if(isroot[i]!=0)
			out[sum++] = isroot[i];
	}
	sort(out,out+sum);
	printf("%d\n",sum);
	for(int i = sum - 1;i >=0;i--){
		printf("%d",out[i]);
		if(i!=0)
			printf(" ");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值