HDU-5512-Pagodas【2015沈阳赛区】

86 篇文章 9 订阅
36 篇文章 0 订阅

HDU-5512-Pagodas


        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1≤a≠b≤n) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j−k. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

Input
The first line contains an integer t (1≤t≤500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2≤n≤20000) and two different integers a and b.

Output
For each test case, output the winner (Yuwgna" orIaka”). Both of them will make the best possible decision each time.

Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12

Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

题目链接:HDU 5512

题目大意:有n-2个被毁坏的宝塔,a,b是好的宝塔。有两个人比赛修复宝塔,每次只能修复第i = j + k or i = j - k (j 和 k是已修复的宝塔位置)

题目思路: gcd(a,b),然后求奇偶性。 比如有10个宝塔,2和8是完整的,那么4,6,10的位置都可以修复。他们的公约数是2,10 / 2 - 2 = 3; 如果5,9是完整的,那么全部位置都可以修复,他们公约数是1。

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;

int gcd(int a, int b)
{    
    return b == 0 ? a : gcd(b, a % b);   
}

int main(){
    int t;
    cin >> t;
    int c = 1;
    while(t--)
    {
        int n,a,b;
        cin >> n >> a >> b;
        printf("Case #%d: ",c++);
        int g = gcd(a,b);
        if ((n / g) % 2 == 0) cout << "Iaka\n";
        else cout << "Yuwgna\n";
    } 

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值