ZOJ-3488-Conic Section【8th浙江省赛】

56 篇文章 0 订阅
5 篇文章 0 订阅

3488-Conic Section


                    Time Limit: 2 Seconds      Memory Limit: 65536 KB

The conic sections are the nondegenerate curves generated by the intersections of a plane with one or two nappes of a cone. For a plane perpendicular to the axis of the cone, a circle is produced. For a plane that is not perpendicular to the axis and that intersects only a single nappe, the curve produced is either an ellipse or a parabola. The curve produced by a plane intersecting both nappes is a hyperbola.
这里写图片描述
Input

There are multiple test cases. The first line of input is an integer T ≈ 10000 indicating the number of test cases.

Each test case consists of a line containing 6 real numbers a, b, c, d, e, f. The absolute value of any number never exceeds 10000. It’s guaranteed that a2+c2>0, b=0, the conic section exists and it is non-degenerate.

Output

For each test case, output the type of conic section ax2+bxy+cy2+dx+ey+f=0. See sample for more details.

Sample Input
5
1 0 1 0 0 -1
1 0 2 0 0 -1
0 0 1 1 0 0
1 0 -1 0 0 1
2 0 2 4 4 0

Sample Output
circle
ellipse
parabola
hyperbola
circle

题目链接:ZOJ-3488

题目大意:给出 ax2+bxy+cy2+dx+ey+f=0 的系数,问是什么图形

题目思路:判断a,c即可。时隔一年再写这题,还是掉到了坑里面去 注意,数字范围是实数!

以下是代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <functional>
#include <numeric>
#include <sstream>
#include <stack>
#include <map>
#include <queue>
#include<iomanip>
using namespace std;
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        double a,b,c,d,e,f;
        cin >> a >> b >> c >> d >> e >> f;
        if (a == c) cout << "circle\n";
        if (a * c > 0 && a != c) cout << "ellipse\n";
        if (a == 0 || c == 0) cout << "parabola\n";
        if (a * c < 0 && a != c) cout << "hyperbola\n";
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值