HDU-5832-A water problem【2016CCPC网络赛】


1001-A water problem


Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output
For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input
10001
0
333

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO

题目链接:HDU-5832

题目大意:水题

以下是代码:

#include <bits/stdc++.h>

using namespace std;

#define mod1 73
#define mod2 137
char s[10000005];
int main(){
    int cas = 1;
    while(~scanf("%s",s))
    {
        int len = strlen(s);
        long long a = 0,b = 0;
        for (int i = 0; i < len; i++)
        {
            a = (a * 10 + s[i] - '0') % mod1;
            b = (b * 10 + s[i] - '0') % mod2;
        }

        if(!a && !b) printf("Case #%d: YES\n",cas++);
        else printf("Case #%d: NO\n",cas++);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值