ZOJ - 2625 (大数)

Rearrange Them

N people stand in a line, and we numbered them 1,2...n, and now you are asked to rearrange them. The ith people is considred in the front of the (i+1)th, after the rearrange, everyone the people in front of whom can not be the same one as before. How many different strategies you can do the rearrange.

Input:

Each test case just contains one integer, the number of people you have to rearrange.

Output:

The number of strategies you have to rearrange them, with the condition above.

Sample Input:

3
4

Sample Output:

3
11
打表找规律,a[n]=(n-1)*a[n-1]+(n-2)*a[n-2];  n<1000;

import java.util.Scanner;
import java.math.BigInteger;
public class Main {

	public static void main(String[] args) {
		BigInteger a[];a=new  BigInteger[10005];
		a[0]=BigInteger.valueOf(0);
		a[1]=BigInteger.valueOf(0);
		a[2]=BigInteger.valueOf(1);
		a[3]=BigInteger.valueOf(3);
		a[4]=BigInteger.valueOf(11);
		for(int i=5;i<=1000;i++) {
			a[i]=a[i-1].multiply(BigInteger.valueOf(i-1)).add(a[i-2].multiply(BigInteger.valueOf(i-2)));
		}
		Scanner  read=new Scanner(System.in);
			int x;
		 while(read.hasNext()){ 
			 x=read.nextInt();
			 System.out.println(a[x]);
		}
	}
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值