Chip Factory (字典树求异或最大值)

 

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces nn chips today, the ii-th chip produced this day has a serial number sisi. 

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below: 

maxi,j,k(si+sj)⊕skmaxi,j,k(si+sj)⊕sk


which i,j,ki,j,k are three different integers between 11 and nn. And ⊕⊕ is symbol of bitwise XOR. 

Can you help John calculate the checksum number of today?

Input

The first line of input contains an integer TT indicating the total number of test cases. 

The first line of each test case is an integer nn, indicating the number of chips produced today. The next line has nn integers s1,s2,..,sns1,s2,..,sn, separated with single space, indicating serial number of each chip. 

1≤T≤10001≤T≤1000 
3≤n≤10003≤n≤1000 
0≤si≤1090≤si≤109 
There are at most 1010 testcases with n>100n>100

Output

For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output 

6
400

 字典树求异或值的时候,先把每个数按照二进制从高位到地位存到树里面,

查找的时候,从最高位开始找相反的结点(0找1,1找0)

#include<set>
#include<map>
#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define ll long long
#define inf 0x3f3f3f
using namespace std;
#define mod 1000000007
const int maxn=100005;
ll a[maxn];
struct node{
    node *son[2];
    ll cut,val;
    node(){
    cut=0;
    val=0;
    son[0]=son[1]=NULL;
    }
};
node *root;
void add(ll x){
    node *p=root,*q;
    for(int i=31;i>=0;i--){
     int y=((x&(1<<i))!=0);
     if(p->son[y]!=NULL){
        p=p->son[y];
     }
     else{
        q=new node;
        p->son[y]=q;
            p=q;
        }
        p->val++;
    }
    p->cut=x;
}
void del(ll x){
    node *p=root;
    for(int i=31;i>=0;i--){
     int y=((x&(1<<i))!=0);
        p=p->son[y];
        p->val--;
    }
}
ll fin(ll x,ll a,ll b){
    node *p=root;
    for(int i=31;i>=0;i--){
        int y=((x&(1<<i))!=0);
        if(p->son[!y]&&p->son[!y]->val){
            p=p->son[!y];}
        else
            p=p->son[y];
    }
    return x^(p->cut);
}
int main(){
    int t;
    scanf("%d",&t);
    for(int I=1;I<=t;I++){
        int n,m;
        root=new node;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%lld",&a[i]);
            add(a[i]);
        }
        ll ans=-1;
        for(int i=0;i<n;i++){
            del(a[i]);
            for(int j=i+1;j<n;j++){
                if(i!=j){
                    del(a[j]);
                    ans=max(ans,fin(a[i]+a[j],a[i],a[j]));
                    add(a[j]);
                }
            }
            add(a[i]);
       }
        printf("%lld\n",ans);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值