poj3046 Ant Counting

题目链接:http://poj.org/problem?id=3046

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, …, B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.
Input

  • Line 1: 4 space-separated integers: T, A, S, and B

  • Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
    Output

  • Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.
    Sample Input

3 5 2 3
1
2
2
1
3
Sample Output

10

题意:
蚂蚁牙黑,蚂蚁牙红:有A只蚂蚁,来自T个家族。同一个家族的蚂蚁长得一样,但是不同家族的蚂蚁牙齿颜色不同。任取n只蚂蚁(S<=n<=B),求能组成几种集合?

分析:
dp[i][j] : 使用前i个家族可以配出来“元素个数为j”的集合的个数。
那么dp[0][0] = 1,不使用任何蚂蚁配出空集的个数为1。

递推关系式:
dp[i][j] = ∑dp[i – 1][j – k] (k∈[ 0,num[i] ] )
由于数据比较大,dp数组开二维显然会爆内存,所以要用到滚动数组

源代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=100005;
const int MOD=1000000;

int dp[2][N];
int num[N];

int main()
{
    int t,n,s,b;
    while(~scanf("%d%d%d%d",&t,&n,&s,&b))
    {
        memset(num,0,sizeof num);
        while(n--)
        {
            int x;
            scanf("%d",&x);
            num[x]++;


        }
        memset(dp,0,sizeof dp);
        int now=0;
        int total=0;
        dp[0][0]=1;
        for(int i=1; i<=t; i++)
        {
            now^=1;
            total+=num[i];
            memset(dp[now],0,sizeof dp[now]);
            for(int j=0; j<=num[i]; j++)
                for(int k=total; k>=j; k--)
                {
                    dp[now][k]=(dp[now][k]+dp[now^1][k-j])%MOD;
                }

        }
        int ans=0;
        for(int i=s; i<=b; i++)
        {
            ans=(ans+dp[now][i])%MOD;
        }
        printf("%d\n",ans);

    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值