2017多校训练Contest4: 1011 Time To Get Up hdu6077

Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38

打表模拟即可

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<string>
#include<sstream>
#include<vector>
using namespace std;

char a[123][123];
char tab[10][7][5] = {
{
".XX.",
"X..X",
"X..X",
"....",
"X..X",
"X..X",
".XX.",
},
{
"....",
"...X",
"...X",
"....",
"...X",
"...X",
"....",
},
{
".XX.",
"...X",
"...X",
".XX.",
"X...",
"X...",
".XX.",
},
{
".XX.",
"...X",
"...X",
".XX.",
"...X",
"...X",
".XX.",
},
{
"....",
"X..X",
"X..X",
".XX.",
"...X",
"...X",
"....",
},
{
".XX.",
"X...",
"X...",
".XX.",
"...X",
"...X",
".XX.",
},
{
".XX.",
"X...",
"X...",
".XX.",
"X..X",
"X..X",
".XX.",
},
{
".XX.",
"...X",
"...X",
"....",
"...X",
"...X",
"....",
},
{
".XX.",
"X..X",
"X..X",
".XX.",
"X..X",
"X..X",
".XX.",
},
{
".XX.",
"X..X",
"X..X",
".XX.",
"...X",
"...X",
".XX.",
},
};

char t[7][5];

bool eq(int x) {
    for(int i=0; i<7; ++i) {
        for(int j=0; j<4; ++j) {
            if(t[i][j] != tab[x][i][j]) return false;
        }
    }
    return true;
}
int f() {
    for(int i=0; i<=9; ++i) if(eq(i)) return i;
}

int main() {
    #ifdef LOCAL
           freopen("in.txt", "r", stdin);
           freopen("out.txt", "w", stdout);
    #endif
    
    int Cases; scanf("%d", &Cases);
    while(Cases--) {
        for(int i=0; i<7; ++i) {
            scanf("%s", a[i]);
        }
        
        for(int i=0; i<7; ++i) {
            for(int j=0; j<4; ++j) {
                t[i][j] = a[i][j];
            }
        }
        printf("%d", f());
        
        for(int i=0; i<7; ++i) {
            for(int j=0; j<4; ++j) {
                t[i][j] = a[i][j+5];
            }
        }
        printf("%d", f());
        
            printf(":");

        for(int i=0; i<7; ++i) {
            for(int j=0; j<4; ++j) {
                t[i][j] = a[i][j+12];
            }
        }
        printf("%d", f());
        
        
        for(int i=0; i<7; ++i) {
            for(int j=0; j<4; ++j) {
                t[i][j] = a[i][j+17];
            }
        }
        printf("%d", f());
        

        
        puts("");
    }
    
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值