poj-3342 Party at Hali-Bula (树形dp入门)

Dear Contestant,

I’m going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I’ve attached the list of employees and the organizational hierarchy of BCM.

Best,
–Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input
The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output
For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input
6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0
Sample Output
4 Yes
1 No

题意

题目要求邀请一些人,但是有直接关系的上下级只能邀请一个,问最多能邀请几个人,并且判断这种情况是否唯一。

思路

开两个二维数组,dp[x][0]代表以x为根节点不邀请x,dp[x][1]代表以x为根节点并且邀请x,状态转移方程:
dp[x][1]=dp[sum[x]][0]; (sum[x]表示x的子节点)因为x已经邀请,所以x的下属自然就不会参加。
dp[x][0]=max(dp[sum[x][0],dp[sum[x]][1]);从子节点中选出最优解。
我们再开一个数组un,un[x][0],un[x][1],用0和1表示此节点是否有唯一解,显然从上述可以看出,dp[x][0]==dp[x][1]时,存在不同解,所以在更新dp时加一个判断即可。

#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
#define maxn 300
using namespace std;
int dp[maxn][2],un[maxn][2];
char ch[maxn][105];
int n,m;
vector<int >tr[maxn];
void dfs(int x)
{
	int i,j,pos;
	vector<int >::iterator p=tr[x].begin();//运用迭代器找出根节点
	dp[x][0]=0,dp[x][1]=1;
	un[x][0]=un[x][1]=1;
	while(p!=tr[x].end())
	{
		dfs(*p);
		dp[x][1]+=dp[*p][0];
		if(!un[*p][0])un[x][1]=0;
		if(dp[*p][1]>dp[*p][0])pos=1;
		else pos=0;
		dp[x][0]+=dp[*p][pos];
		if(!un[*p][pos]||dp[*p][1]==dp[*p][0])un[x][pos]=0;
		++p;
	}
}
int main()
{
	int i,j,pos1,pos2;
	while(scanf("%d",&n)&&n)
	{
		for(i=0;i<n;i++)tr[i].clear();
		scanf("%s",&ch[0]);
		m=1;
		for(i=1;i<n;i++){
			scanf("%s",&ch[m]);
			for(j=0;j<m;j++){
				if(!strcmp(ch[j],ch[m]))break;
			}		
			if(j==m)++m;
			pos1=j;
			scanf("%s",&ch[m]);
			for(j=0;j<m;j++){
				if(!strcmp(ch[j],ch[m]))break;
			}
			if(j==m)++m;
			pos2=j;
			tr[pos2].push_back(pos1);
		}
		dfs(0);
		if(dp[0][1]>dp[0][0])pos1=1;
		else pos1=0;
		printf("%d ",dp[0][pos1]);
		if(dp[0][1]==dp[0][0]||!un[0][pos1])printf("No\n");
		else printf("Yes\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值