poj 3342 Party at Hali-Bula(树形dp)

Party at Hali-Bula
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6320 Accepted: 2254

Description

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input

The input consists of multiple test cases. Each test case is started with a line containing an integern (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the followingn-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output

4 Yes
1 No
1 No


题目链接:http://poj.org/problem?id=3342


题意:有个人要开party,邀请公司同事参加,邀请的同事不能有直接的上下级关系,并且只有一个boss,给你同事间的关系(n-1组)后面的是前面的直属上司,问最多可以邀请
多少人参加party,并且问邀请的人是否的唯一的。

思路:
最多邀请得人数很easy,树形dp,每个节点分为选和不选两种,分别求最大值就好了

状态转移:
        dp[s][1]+=dp[nextv][0];
        dp[s][0]+=max(dp[nextv][1],dp[nextv][0]);
nextv 为s的下属,也就是子节点。
dp[s][1]代表选择这个节点时,则直接加上子节点不选的总和。
dp[s][0]代表不选这个节点。

那如何判断是否唯一呢????????

由递推式可以看出,当不选的时候有取最大值操作。
那很容易可以看出:
当两者相等的时候对dp[s][0]是有两种选择,即不唯一。
我们可以定义ok数组表示当前位置是否唯一。
        dp[s][1]+=dp[nextv][0];
        ok[s][1]+=ok[nextv][0];
        dp[s][0]+=max(dp[nextv][1],dp[nextv][0]);
        if(dp[nextv][1]==dp[nextv][0])
        {
            ok[s][0]=1;
        }
        else if(dp[nextv][1]>dp[nextv][0])
            ok[s][0]+=ok[nextv][1];
        else
            ok[s][0]+=ok[nextv][0];

容易看出,在取最大值操作的时候,若两者相等,选择不唯一,标记为1;
其他的只是递推过程。

完整代码:
#include<stdio.h>
#include<vector>
#include<string.h>
#include<map>
#include<string>
#include<iostream>
using namespace std;
const int maxn=222;
vector<int>v[maxn];
map<string,int>p;
int dp[maxn][2],vis[maxn],ok[maxn][2];
void dfs(int s)
{
    int n=v[s].size();
    vis[s]=1;
    for(int i=0;i<n;i++)
    {
        int nextv=v[s][i];
        if(vis[nextv])continue;
        dfs(nextv);
        dp[s][1]+=dp[nextv][0];
        ok[s][1]+=ok[nextv][0];
        dp[s][0]+=max(dp[nextv][1],dp[nextv][0]);
        if(dp[nextv][1]==dp[nextv][0])
        {
            ok[s][0]=1;
        }
        else if(dp[nextv][1]>dp[nextv][0])
            ok[s][0]+=ok[nextv][1];
        else
            ok[s][0]+=ok[nextv][0];
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        memset(ok,0,sizeof(ok));
        for(int i=1;i<=n;i++)
            v[i].clear();
        for(int i=1;i<=n;i++)
            dp[i][1]=1;
        p.clear();
        string s1,s2;
        cin>>s1;
        int len=1;
        p[s1]=len++;
        for(int i=0;i<n-1;i++)
        {
            int a,b;
            cin>>s1>>s2;
            if(!p[s1])
                p[s1]=len++;
            if(!p[s2])
                p[s2]=len++;
            a=p[s1];b=p[s2];
            v[b].push_back(a);
        }
        dfs(1);
        int ans=max(dp[1][0],dp[1][1]);
        printf("%d ",ans);
        if(dp[1][0]==dp[1][1])
            printf("No\n");
        else if(dp[1][0]>dp[1][1]&&!ok[1][0])
            printf("Yes\n");
        else if(!ok[1][1])
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}







 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值