HDU 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    MemoryLimit: 65536/32768 K (Java/Others)
Total Submission(s): 16720    Accepted Submission(s): 7132


Problem Description

Givena string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to"kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

 

 

Input

Thefirst line contains an integer N (1 <= N <= 100) which indicates thenumber of test cases. The next N lines contain N strings. Each string consistsof only 'A' - 'Z' and the length is less than 10000.

 

 

Output

Foreach test case, output the encoded string in a line.

 

 

Sample Input

2

ABC

ABBCCC

 

 

Sample Output

ABC

A2B3C

 

 

Author

ZHANGZheng

 

 

Recommend

JGShining

 

Hdu1020解题思路:被题目的用例所误导了,看到用例,误以为本题的统计是按字典序输出的,还有一个误区就,统计的整一个字符串中出现相同字符,一开始想到了用map做,我的解题思路是,接收字符串,通过后一个字符与前一个字符进行比较,如果相同则计数器cnt++,再按照格式输出;

2012-08-17 00:32:44

Accepted

1020

0MS

228K

451 B

GCC


#include <stdio.h>
#include <string.h>
#define  nMax 100001
char s[nMax];
int main(int argc, char *argv[])
{
    int cas,i;
    scanf("%d",&cas);
    while(cas--)
    {
        int len,cnt=1;
        scanf("%s",s);
        len=strlen(s);
        for(i=0; i<len; i++)
        {
            if(s[i]!=s[i+1])
            {
                if(cnt==1)
                    printf("%c",s[i]);
                else
                    printf("%d%c",cnt,s[i]);
                cnt=1;
            }
            else
            {
                cnt++;    
            }    
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值